Read the docs
TI-2024-09091 Aliases CVE-2024-9796GHSA-hxx7-vhm6-3427

WP-Advanced-Search < 3.3.9.2 - Unauthenticated SQL Injection

Priority HIGH 76CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The WP-Advanced-Search WordPress plugin before 3.3.9.2 does not sanitize and escape the t parameter before using it in a SQL statement, allowing unauthenticated users to perform SQL injection attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02996 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP-Advanced-Search (Unknown): 3.3.9.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP-Advanced-Searchbefore 3.3.9.23.3.9.2Patch availableCNA
  • WP-Advanced-Search VendorUnknown Affected before 3.3.9.2 Fixed in 3.3.9.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:internet-formation:wp-advanced-search:*:*:*:*:*:wordpress:*:*before 3.3.9.2VulnerableInternet-formation
  • cpe:2.3:a:internet-formation:wp-advanced-search:*:*:*:*:*:wordpress:*:* Versions before 3.3.9.2 Vulnerable ·Internet-formation

Remediation

  • Fix · CNA WP-Advanced-Search (Unknown) Fixed in 3.3.9.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-9796
  2. 2026-10-03 Alias added: GHSA-hxx7-vhm6-3427

References

  • TI-2024-09777 WP-Advanced-Search < 3.3.9.3 - Admin+ Stored XSS CVSS 3.1LOW 3.5
  • TI-2020-09739 The Import feature in the wp-advanced-search plugin 3.3.6 for WordPress is vulnerable to… CVSS 3.1HIGH 8.8
  • TI-2022-23524 WordPress WP-Advanced-Search Plugin <= 3.3.8 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8

Sources