WP-Advanced-Search < 3.3.9.3 - Admin+ Stored XSS
Priority MEDIUM 50CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress WP-Advanced-Search WordPress plugin before 3.3.9.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00324 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WordPress WP-Advanced-Search (Unknown): 3.3.9.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress WP-Advanced-Search | before 3.3.9.3 | 3.3.9.3 | Patch available | CNA |
- WordPress WP-Advanced-Search VendorUnknown Affected before 3.3.9.3 Fixed in 3.3.9.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:internet-formation:wp-advanced-search:*:*:*:*:*:wordpress:*:* | before 3.3.9.3 | Vulnerable | Internet-formation |
- cpe:2.3:a:internet-formation:wp-advanced-search:*:*:*:*:*:wordpress:*:* Versions before 3.3.9.3 Vulnerable ·Internet-formation
Remediation
- Fix · CNA WordPress WP-Advanced-Search (Unknown) Fixed in 3.3.9.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10554
- 2026-10-03 Alias added: GHSA-q27q-f4wr-gh4j
References
More Internet-formation Wp-advanced-search vulnerabilities
- TI-2024-09091 WP-Advanced-Search < 3.3.9.2 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2020-09739 The Import feature in the wp-advanced-search plugin 3.3.6 for WordPress is vulnerable to… CVSS 3.1HIGH 8.8
- TI-2022-23524 WordPress WP-Advanced-Search Plugin <= 3.3.8 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2024-10554 · CVE Program
- CVE-2024-10554 · NVD
- FIRST EPSS
- GHSA-q27q-f4wr-gh4j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences