Read the docs
TI-2024-10004 Aliases CVE-2024-10792

Easiest Funnel Builder For WordPress & WooCommerce by WPFunnels <= 3.5.5 - Reflected Cross-Site Scripting

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The Easiest Funnel Builder For WordPress & WooCommerce by WPFunnels plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'post_id' parameter in all versions up to, and including, 3.5.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This was partially patched in 3.5.4 and fully patched in 3.5.5.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00644 51st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getwpfunnelsWPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsellup to 3.5.5—No fix listedCNA
  • WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell Vendorgetwpfunnels Affected up to 3.5.5 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-10792
  2. 2026-10-30 EPSS moved to the 50th–90th percentile

References

  • TI-2023-00167 WPFunnels < 2.6.9 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2026-12131 WPFunnels <= 3.12.7 - Unauthenticated Remote Code Execution via 'postData' Parameter CVSS 3.1CRITICAL 9.8
  • TI-2026-08934 Mail Mint <= 1.31.0 - Unauthenticated PHP Object Injection in Arbitrary Form Fields CVSS 3.1CRITICAL 9.8
  • TI-2026-12715 WPFunnels <= 3.12.8 - Authenticated (Funnel Manager+) Privilege Escalation via 'group_id' Path Parameter CVSS 3.1HIGH 8.8
  • TI-2025-14000 Missing authorization in getwpfunnels Creator LMS – Online Courses and eLearning Plugin CVSS 3.1HIGH 8.8
  • TI-2026-11129 WPFunnels <= 3.12.7 - Authenticated (Administrator+) Local File Inclusion via 'logKey' Parameter CVSS 3.1MEDIUM 6.6
See all 19 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences