Jetpack 13.0-14.0 - Unauthenticated DOM-XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Jetpack WordPress plugin before 14.1 does not properly checks the postmessage origin in its 13.x versions, allowing it to be bypassed and leading to DOM-XSS. The issue only affects websites hosted on WordPress.com.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00404 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Jetpack (Unknown): 14.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Jetpack | 13.0 to before 14.1 | 14.1 | Patch available | CNA |
- Jetpack VendorUnknown Affected 13.0 to before 14.1 Fixed in 14.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:automattic:jetpack:*:*:*:*:*:wordpress:*:* | before 14.1 | Vulnerable | Automattic |
- cpe:2.3:a:automattic:jetpack:*:*:*:*:*:wordpress:*:* Versions before 14.1 Vulnerable ·Automattic
Remediation
- Fix · CNA Jetpack (Unknown) Fixed in 14.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10858
- 2026-10-03 Alias added: GHSA-pjm4-fjw9-x2fh
References
More Automattic Jetpack vulnerabilities
- TI-2023-02806 Jetpack < 12.1.1 - Author+ Arbitrary File Manipulation via API CVSS 3.1HIGH 8.8
- TI-2024-09340 Jetpack < 13.8, Boost < 3.4.8 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2024-09339 Jetpack < 13.8 - Unauthenticated Arbitrary Block & Shortcode Execution CVSS 3.1MEDIUM 5.6
- TI-2023-30606 Jetpack 11.4 - Cross Site Scripting (XSS) CVSS 4.0MEDIUM 5.1
- TI-2023-25898 WordPress Jetpack plugin < 12.7 - Contributor+ Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2011-04017 SQL injection vulnerability in modules/sharedaddy.php in the Jetpack plugin for WordPress… CVSS 2.0HIGH 7.5
Sources
- CVE-2024-10858 · CVE Program
- CVE-2024-10858 · NVD
- FIRST EPSS
- GHSA-pjm4-fjw9-x2fh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences