Missing authorization in RadiusTheme Classified Listing – AI-Powered Classified ads &…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Classified Listing – Classified ads & Business Directory Plugin plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a misconfigured check on the 'rtcl_import_settings' function in all versions up to, and including, 3.1.15.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update limited arbitrary options on the WordPress site. This can be leveraged to update the Subscriber role with Administrator-level capabilities to gain administrative user access to a vulnerable site. The vulnerability is limited in that the option updated must have a value that is an array.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| RadiusTheme | Classified Listing – AI-Powered Classified ads & Business Directory Plugin | up to 3.1.15.1 | — | No fix listed | CNA |
- Classified Listing – AI-Powered Classified ads & Business Directory Plugin VendorRadiusTheme Affected up to 3.1.15.1 Fixed in — No fix listed CNA
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:techlabpro1:classified_listing_plugin:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:techlabpro1:classified_listing_plugin:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-11194
- 2026-10-03 Alias added: GHSA-gmh4-w5mw-qw74
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/13d9a59f-1a1a-4936-a5ab-8a5e0c50303b?source=cve
- https://plugins.trac.wordpress.org/browser/classified-listing/tags/3.1.12/app/Controllers/Ajax/Import.php#L473
- https://plugins.trac.wordpress.org/browser/classified-listing/tags/3.1.12/app/Controllers/Ajax/Import.php#L309
- https://plugins.trac.wordpress.org/changeset/3189516/
More RadiusTheme vulnerabilities
- TI-2022-02454 Classima < 2.1.11 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-26399 WordPress Plugin Testimonial Slider and Showcase 2.2.6 Stored XSS CVSS 4.0MEDIUM 5.1
- TI-2024-08572 Team Members Showcase < 4.4.2 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-03390 The Post Grid < 7.5.0 - Editor+ Stored XSS via Grid Creation CVSS 3.1MEDIUM 4.8
- TI-2024-01623 Testimonial Slider < 2.3.7 - Author+ Settings Update CVSS 3.1MEDIUM 4.3
- TI-2026-67962 SQL injection in RadiusTheme Radius Booking WordPress plugin CVSS 3.1CRITICAL 9.3
Sources
- CVE-2024-11194 · CVE Program
- CVE-2024-11194 · NVD
- FIRST EPSS
- GHSA-gmh4-w5mw-qw74 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences