Email Subscribers < 5.7.52 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Icegram Express formerly known as Email Subscribers WordPress plugin before 5.7.52 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Icegram Express formerly known as Email Subscribers | before 5.7.52 | 5.7.52 | Patch available | CNA |
- Icegram Express formerly known as Email Subscribers VendorUnknown Affected before 5.7.52 Fixed in 5.7.52 Patch available CNA
Remediation
- Fix · CNA Icegram Express formerly known as Email Subscribers (Unknown) Fixed in 5.7.52
Timeline
- 2026-10-02 Threatist record created from CVE-2024-11924
- 2026-10-03 Alias added: GHSA-p345-jmhp-7wg2
References
More Icegram Express vulnerabilities
- TI-2025-00565 Email Subscribers < 5.7.50 - Admin+ Stored XSS in Template CVSS 3.1MEDIUM 6.1
- TI-2024-05345 SQL injection in icegram Email Subscribers & Newsletters – Email Marketing, Post… CVSS 3.1CRITICAL 9.8
- TI-2022-22614 WordPress Email Subscribers & Newsletters Plugin <= 5.5.2 is vulnerable to CSV Injection CVSS 3.1CRITICAL 9.8
- TI-2023-04985 Icegram Express <= 5.6.23 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Read CVSS 3.1CRITICAL 9.1
- TI-2024-04508 Icegram Express <= 5.7.22 - Authenticated (Subscriber+) SQL Injection Vulnerability via options[list_id] CVSS 3.1HIGH 8.8
- TI-2024-14434 WordPress Icegram Engage plugin <= 3.1.21 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-11924 · CVE Program
- CVE-2024-11924 · NVD
- FIRST EPSS
- GHSA-p345-jmhp-7wg2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences