Email Subscribers < 5.7.50 - Admin+ Stored XSS in Template
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Icegram Express WordPress plugin before 5.7.50 does not sanitise and escape some of its Template settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00285 21st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Icegram Express (Unknown): 5.7.50
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Icegram Express | before 5.7.50 | 5.7.50 | Patch available | CNA |
- Icegram Express VendorUnknown Affected before 5.7.50 Fixed in 5.7.50 Patch available CNA
Remediation
- Fix · CNA Icegram Express (Unknown) Fixed in 5.7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2025-0671
- 2026-10-03 Alias added: GHSA-4c3f-c9v6-jqxm
References
More Icegram Express vulnerabilities
- TI-2024-11063 Email Subscribers < 5.7.52 - Admin+ Stored XSS CVSS 3.1LOW 3.5
- TI-2024-05345 SQL injection in icegram Email Subscribers & Newsletters – Email Marketing, Post… CVSS 3.1CRITICAL 9.8
- TI-2022-22614 WordPress Email Subscribers & Newsletters Plugin <= 5.5.2 is vulnerable to CSV Injection CVSS 3.1CRITICAL 9.8
- TI-2023-04985 Icegram Express <= 5.6.23 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Read CVSS 3.1CRITICAL 9.1
- TI-2024-04508 Icegram Express <= 5.7.22 - Authenticated (Subscriber+) SQL Injection Vulnerability via options[list_id] CVSS 3.1HIGH 8.8
- TI-2024-14434 WordPress Icegram Engage plugin <= 3.1.21 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2025-0671 · CVE Program
- CVE-2025-0671 · NVD
- FIRST EPSS
- GHSA-4c3f-c9v6-jqxm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences