Master Slider < 3.10.5 - Editor+ Stored XSS
Priority MEDIUM 50CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Master Slider WordPress plugin before 3.10.5 does not sanitise and escape some of its settings, which could allow high privilege users such as Editor and above to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0034 27th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Master Slider (Unknown): 3.10.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Master Slider | before 3.10.5 | 3.10.5 | Patch available | CNA |
- Master Slider VendorUnknown Affected before 3.10.5 Fixed in 3.10.5 Patch available CNA
Remediation
- Fix · CNA Master Slider (Unknown) Fixed in 3.10.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12173
- 2026-10-03 Alias added: GHSA-pqch-79w5-3vfc
References
More averta Master Slider vulnerabilities
- TI-2024-06019 Master Slider – Responsive Touch Slider <= 3.9.10 - CSRF to slider deletion CVSS 3.1MEDIUM 6.5
- TI-2024-21487 WordPress Master Slider plugin <= 3.9.5 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.6
- TI-2024-24737 WordPress Master Slider plugin <= 3.10.0 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-25679 WordPress Master Slider Pro Plugin <= 3.6.5 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-21467 WordPress Master Slider plugin <= 3.9.8 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-01353 Master Slider – Responsive Touch Slider <= 3.9.10 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-12173 · CVE Program
- CVE-2024-12173 · NVD
- FIRST EPSS
- GHSA-pqch-79w5-3vfc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences