Pega Platform versions 8.1 to Infinity 24.2.0 are affected by an Stored XSS issue with profile.
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Pega Platform versions 8.1 to Infinity 24.2.0 are affected by an Stored XSS issue with profile.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Fix Fixed Pega Infinity (Pegasystems): 24.2.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pegasystems | Pega Infinity | 8.1 to before 24.2.1 | 24.2.1 | Patch available | CNA |
- Pega Infinity VendorPegasystems Affected 8.1 to before 24.2.1 Fixed in 24.2.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* | 8.1 to before 23.1.4; 24.1.0 to before 24.1.2 | Vulnerable | Pegasystems |
| cpe:2.3:a:pega:pega_platform:24.2.0:*:*:*:*:*:*:* | 24.2.0 | Vulnerable | Pegasystems |
- cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* Versions 8.1 to before 23.1.4; 24.1.0 to before 24.1.2 Vulnerable ·Pegasystems
- cpe:2.3:a:pega:pega_platform:24.2.0:*:*:*:*:*:*:* Versions 24.2.0 Vulnerable ·Pegasystems
Remediation
- Fix · CNA Pega Infinity (Pegasystems) Fixed in 24.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12211
References
More Pegasystems Pega Platform vulnerabilities
- TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
- TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
- TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
- TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
- TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
- TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences