Email Subscribers < 5.7.45 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Email Subscribers by Icegram Express WordPress plugin before 5.7.45 does not sanitise and escape some of its Workflow settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Email Subscribers by Icegram Express | before 5.7.45 | 5.7.45 | Patch available | CNA |
- Email Subscribers by Icegram Express VendorUnknown Affected before 5.7.45 Fixed in 5.7.45 Patch available CNA
Remediation
- Fix · CNA Email Subscribers by Icegram Express (Unknown) Fixed in 5.7.45
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Email Subscribers by Icegram Express 5.7.45
4 records Highest priority Priority MEDIUM 4 MEDIUM
Other records, highest priority first
- TI-2024-11660 Email Subscribers < 5.7.45 - Admin+ Stored XSSPriority MEDIUM 55
- TI-2024-11659 Email Subscribers < 5.7.45 - Admin+ Stored XSSPriority MEDIUM 55
- TI-2024-10783 Email Subscribers < 5.7.45 - Admin+ Stored XSSPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12568
- 2026-10-03 Alias added: GHSA-6qmq-j47c-v4fj
References
More icegram Email Subscribers & Newsletters vulnerabilities
- TI-2019-14600 There was a flaw in the WordPress plugin, Email Subscribers & Newsletters before 4.3.1… CVSS 3.1CRITICAL 9.8
- TI-2022-03650 Icegram Express < 5.5.1 - Subscriber+ SQLi CVSS 3.1HIGH 8.8
- TI-2024-11421 Email Subscribers < 5.7.44 - Admin+ SQL Injection CVSS 3.1MEDIUM 6.5
- TI-2019-14413 The WordPress plugin, Email Subscribers & Newsletters, before 4.2.3 had a flaw that… CVSS 3.1MEDIUM 5.3
- TI-2024-11660 Email Subscribers < 5.7.45 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-11659 Email Subscribers < 5.7.45 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-12568 · CVE Program
- CVE-2024-12568 · NVD
- FIRST EPSS
- GHSA-6qmq-j47c-v4fj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences