The Ultimate WordPress Toolkit – WP Extended <= 3.0.12 - Unauthenticated SQL Injection via Login Attempts Module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to time-based SQL Injection via the Login Attempts module in all versions up to, and including, 3.0.12 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpextended | The Ultimate WordPress Toolkit – WP Extended | up to 3.0.12 | — | No fix listed | CNA |
- The Ultimate WordPress Toolkit – WP Extended Vendorwpextended Affected up to 3.0.12 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:*:*:* | — | — | wpextended |
- cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:*:*:* Versions — — ·wpextended
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13184
- 2026-10-03 Alias added: GHSA-m97v-32rg-wq3h
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/abab29c7-88a9-4c6f-9691-ed9087cde2ff?source=cve
- https://plugins.trac.wordpress.org/browser/wpextended/trunk/includes/modules/core_extensions/wpext_limit_login_attempts/wpext_limit_login_attempts.php#L105
- https://wordpress.org/plugins/wpextended/#developers
- https://plugins.trac.wordpress.org/changeset/3220003/
More wpextended vulnerabilities
- TI-2024-07515 Path traversal in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-10960 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-07513 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-03755 Improper privilege management in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-24774 WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-11055 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 7.4
Sources
- CVE-2024-13184 · CVE Program
- CVE-2024-13184 · NVD
- FIRST EPSS
- GHSA-m97v-32rg-wq3h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences