WP Responsive Tabs <= 1.2.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Responsive Tabs plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wprtabs' shortcode in all versions up to, and including, 1.2.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fahadmahmood | WP Responsive Tabs | up to 1.2.9 | — | No fix listed | CNA |
- WP Responsive Tabs Vendorfahadmahmood Affected up to 1.2.9 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13387
- 2026-10-03 Alias added: GHSA-j43c-5jq7-2fq7
References
More fahadmahmood vulnerabilities
- TI-2025-07361 Injection Guard < 1.2.8 - Reflected XSS via $_SERVER['REQUEST_URI'] CVSS 3.1MEDIUM 6.1
- TI-2025-07132 WP Shopify < 1.5.4 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2024-09127 RSS Feed Widget < 3.0.1 - Reflected XSS CVSS 3.1MEDIUM 4.8
- TI-2025-11633 Easy Upload Files During Checkout <= 2.9.8 - Unauthenticated Arbitrary JavaScript File Upload CVSS 3.1CRITICAL 9.8
- TI-2024-03635 WP Datepicker <= 2.1.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-02908 Injection Guard <= 1.2.9 - Unauthenticated Stored Cross-Site Scripting via Query Parameter Name CVSS 3.1HIGH 7.2
Sources
- CVE-2024-13387 · CVE Program
- CVE-2024-13387 · NVD
- FIRST EPSS
- GHSA-j43c-5jq7-2fq7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences