TagDiv Composer <= 5.3 - Unauthenticated Arbitrary PHP Object Instantiation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
The tagDiv Composer plugin for WordPress is vulnerable to PHP Object Instantiation in all versions up to, and including, 5.3 via module parameter. This makes it possible for unauthenticated attackers to Instantiate a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13645
- 2026-10-03 Alias added: GHSA-8mmw-qfv3-2mgw
References
More tagDiv vulnerabilities
- TI-2022-03209 tagDiv Composer < 3.5 - Unauthenticated Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2023-01506 tagDiv Cloud Library < 2.7 - Unauthenticated Arbitrary User Metadata Update to Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2023-02969 tagDiv Composer < 4.2 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-01505 tagDiv Composer < 4.0 - Reflected Cross-site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-02429 Newspaper < 12 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-02005 Newspaper < 12 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-13645 · CVE Program
- CVE-2024-13645 · NVD
- FIRST EPSS
- GHSA-8mmw-qfv3-2mgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences