Read the docs
TI-2024-12900 Aliases CVE-2024-13879GHSA-fjjc-v9rc-xhj8

Stream <= 4.0.2 - Authenticated (Admin+) Server-Side Request Forgery

Priority LOW 25CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

The Stream plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 4.0.2 due to insufficient validation on the webhook feature. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00349 28th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
xwpStreamup to 4.0.2—No fix listedCNA
  • Stream Vendorxwp Affected up to 4.0.2 Fixed in — No fix listed CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:xwp:stream:*:*:*:*:*:*:*:*——xwp
  • cpe:2.3:a:xwp:stream:*:*:*:*:*:*:*:* Versions — — ·xwp

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-13879
  2. 2026-10-03 Alias added: GHSA-fjjc-v9rc-xhj8

References

  • TI-2022-04015 Stream < 3.9.2 - Subscriber+ Alert Creation CVSS 3.1MEDIUM 6.5
  • TI-2021-07054 Stream < 3.8.2 - Admin+ SQL Injection CVSS 3.1HIGH 8.8
  • TI-2024-06879 Stream <= 4.0.1 - Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2022-21279 WordPress Stream Plugin <= 3.9.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2022-21242 WordPress Stream Plugin <= 3.9.2 is vulnerable to Insecure Direct Object References (IDOR) CVSS 3.1MEDIUM 6.5
  • TI-2026-10273 Missing authorization in xwp Stream – Activity Log & Audit Trail CVSS 3.1MEDIUM 6.5

Sources