Read the docs
TI-2026-10273 Aliases CVE-2026-11907GHSA-vq9h-6p44-rphw

Missing authorization in xwp Stream – Activity Log & Audit Trail

Priority LOW 29CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The Stream plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.2.0. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to access all Stream activity records via the Heartbeat API.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00375 31st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
xwpStream – Activity Log & Audit Trailup to 4.2.0—No fix listedCNA
  • Stream – Activity Log & Audit Trail Vendorxwp Affected up to 4.2.0 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-11907
  2. 2026-10-03 Alias added: GHSA-vq9h-6p44-rphw

References

  • TI-2022-04015 Stream < 3.9.2 - Subscriber+ Alert Creation CVSS 3.1MEDIUM 6.5
  • TI-2021-07054 Stream < 3.8.2 - Admin+ SQL Injection CVSS 3.1HIGH 8.8
  • TI-2024-06879 Stream <= 4.0.1 - Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2022-21279 WordPress Stream Plugin <= 3.9.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2022-21242 WordPress Stream Plugin <= 3.9.2 is vulnerable to Insecure Direct Object References (IDOR) CVSS 3.1MEDIUM 6.5
  • TI-2024-12900 Stream <= 4.0.2 - Authenticated (Admin+) Server-Side Request Forgery CVSS 3.1MEDIUM 5.5

Sources