Read the docs
TI-2024-14347 Aliases CVE-2024-21622GHSA-j5g9-j7r4-6qvx

Craft CMS Privilege Escalation

Priority LOW 39CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.

Summary

Craft is a content management system. This is a potential moderate impact, low complexity privilege escalation vulnerability in Craft starting in 3.x prior to 3.9.6 and 4.x prior to 4.4.16 with certain user permissions setups. This has been fixed in Craft 4.4.16 and Craft 3.9.6. Users should ensure they are running at least those versions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00588 48th percentileScored 2026-11-07
Fix Fixed cms (craftcms): 4.5.11, 3.9.6craftcms/cms (Packagist): 4.5.11, 3.9.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Craft CMScms4.0.0-RC1 to before 4.5.11; 3.0.0 to before 3.9.64.5.11, 3.9.6Patch availableCNA
—craftcms/cms (Packagist)4.0.0-RC1 to before 4.5.114.5.11Patch availableGHSA-j5g9-j7r4-6qvx
—craftcms/cms (Packagist)3.0.0 to before 3.9.63.9.6Patch availableGHSA-j5g9-j7r4-6qvx
  • cms VendorCraft CMS Affected 4.0.0-RC1 to before 4.5.11; 3.0.0 to before 3.9.6 Fixed in 4.5.11, 3.9.6 Patch available CNA
  • craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.5.11 Fixed in 4.5.11 Patch available GHSA-j5g9-j7r4-6qvx
  • craftcms/cms (Packagist) Vendor— Affected 3.0.0 to before 3.9.6 Fixed in 3.9.6 Patch available GHSA-j5g9-j7r4-6qvx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:*3.0.0 to before 3.9.6; 4.0.0 – 4.5.15VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.9.6; 4.0.0 – 4.5.15 Vulnerable ·Craft CMS

Remediation

  • Fix · CNA cms (craftcms) Fixed in 4.5.11, 3.9.6
  • Fix · GHSA-j5g9-j7r4-6qvx craftcms/cms (Packagist) Fixed in 4.5.11 Advisory →
  • Fix · GHSA-j5g9-j7r4-6qvx craftcms/cms (Packagist) Fixed in 3.9.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-21622
  2. 2026-10-03 Alias added: GHSA-j5g9-j7r4-6qvx

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources