Read the docs
TI-2024-14404 Aliases CVE-2024-21689GHSA-h63c-4f8g-75qg

Code injection in Atlassian Bamboo Data Center

Priority MEDIUM 42CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.

Summary

This High severity RCE (Remote Code Execution) vulnerability CVE-2024-21689  was introduced in versions 9.1.0, 9.2.0, 9.3.0, 9.4.0, 9.5.0, and 9.6.0 of Bamboo Data Center and Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 7.6, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires user interaction. Atlassian recommends that Bamboo Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Bamboo Data Center and Server 9.2: Upgrade to a release greater than or equal to 9.2.17 Bamboo Data Center and Server 9.6: Upgrade to a release greater than or equal to 9.6.5 See the release notes ([https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html]). You can download the latest version of Bamboo Data Center and Server from the download center ([https://www.atlassian.com/software/bamboo/download-archives]). This vulnerability was reported via our Bug Bounty program.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02647 85th percentileScored 2026-11-07
Fix Fixed Bamboo Data Center (Atlassian): 9.6.5, 9.2.17Bamboo Server (Atlassian): 9.2.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AtlassianBamboo Data Center9.6.0 to 9.6.4; 9.5.0 to 9.5.4; 9.4.0 to 9.4.4; 9.3.0 to 9.3.6; 9.2.1 to 9.2.16; 9.1.0 to 9.1.39.6.5, 9.2.17Patch availableCNA
AtlassianBamboo Server9.4.0 to 9.4.4; 9.3.0 to 9.3.6; 9.2.1 to 9.2.16; 9.1.0 to 9.1.39.2.17Patch availableCNA
  • Bamboo Data Center VendorAtlassian Affected 9.6.0 to 9.6.4; 9.5.0 to 9.5.4; 9.4.0 to 9.4.4; 9.3.0 to 9.3.6; 9.2.1 to 9.2.16; 9.1.0 to 9.1.3 Fixed in 9.6.5, 9.2.17 Patch available CNA
  • Bamboo Server VendorAtlassian Affected 9.4.0 to 9.4.4; 9.3.0 to 9.3.6; 9.2.1 to 9.2.16; 9.1.0 to 9.1.3 Fixed in 9.2.17 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:atlassian:bamboo:*:*:*:*:*:*:*:*9.1.0 to before 9.2.17; 9.3.0 to before 9.6.5VulnerableAtlassian
  • cpe:2.3:a:atlassian:bamboo:*:*:*:*:*:*:*:* Versions 9.1.0 to before 9.2.17; 9.3.0 to before 9.6.5 Vulnerable ·Atlassian

Remediation

  • Fix · CNA Bamboo Data Center (Atlassian) Fixed in 9.6.5, 9.2.17
  • Fix · CNA Bamboo Server (Atlassian) Fixed in 9.2.17

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-21689
  2. 2026-10-03 Alias added: GHSA-h63c-4f8g-75qg

References

  • TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
  • TI-2012-02540 Atlassian JIRA before 5.0.1; Confluence before 3.5.16, 4.0 before 4.0.7, and 4.1 before… CVSS 3.1CRITICAL 9.1
  • TI-2022-09598 Improper authentication in Atlassian Bamboo Server CVSS 3.1CRITICAL 9.8
  • TI-2016-04529 Atlassian Bamboo before 5.11.4.1 and 5.12.x before 5.12.3.1 does not properly restrict… CVSS 3.0CRITICAL 9.8
  • TI-2015-06881 An unspecified resource in Atlassian Bamboo before 5.9.9 and 5.10.x before 5.10.0 allows… CVSS 3.0CRITICAL 9.8
  • TI-2014-07936 The Ignite Realtime Smack XMPP API, as used in Atlassian Bamboo before 5.9.9 and 5.10.x… CVSS 3.0CRITICAL 9.8
See all 27 →

Sources