Read the docs
TI-2024-14553 Aliases CVE-2024-21892GHSA-f27j-4f6g-jp27

Improper privilege management in NodeJS Node

Priority LOW 37CWE-269Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation, Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-269 and CWE-94.

Summary

On Linux, Node.js ignores certain environment variables if those may have been set by an unprivileged user while the process is running with elevated privileges with the only exception of CAP_NET_BIND_SERVICE. Due to a bug in the implementation of this exception, Node.js incorrectly applies this exception even when certain other capabilities have been set. This allows unprivileged users to inject code that inherits the process's elevated privileges.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00562 46th percentileScored 2026-11-07
Fix Fixed Node (NodeJS): 18.19.1, 20.11.1, 21.6.2Red Hat: 6 advisories

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
NodeJSNode4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.19.1; 19.0 and later; 20.0 to before 20.11.1; 21.0 to before 21.6.218.19.1, 20.11.1, 21.6.2Patch availableCNA
  • Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.19.1; 19.0 and later; 20.0 to before 20.11.1; 21.0 to before 21.6.2 Fixed in 18.19.1, 20.11.1, 21.6.2 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*18.0.0 to before 18.19.1; 20.0.0 to before 20.11.1; 21.0.0 to before 21.6.2VulnerableNodeJS
cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:*not specified by NVDRunning onLinux
  • cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* Versions 18.0.0 to before 18.19.1; 20.0.0 to before 20.11.1; 21.0.0 to before 21.6.2 Vulnerable ·NodeJS
  • cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux

Remediation

  • Fix · CNA Node (NodeJS) Fixed in 18.19.1, 20.11.1, 21.6.2

Red Hat 6 advisories

  • RHSA-2024:1932 Released 2024-04-22 · Red Hat rating Important
    nodejs:18 security update
    • Red Hat Enterprise Linux AppStream EUS (v.9.2) nodejs-1:18.19.1-1.module+el9.2.0+21594+a052107e.aarch64::nodejs:18, nodejs-1:18.19.1-1.module+el9.2.0+21594+a052107e.ppc64le::nodejs:18, nodejs-1:18.19.1-1.module+el9.2.0+21594+a052107e.s390x::nodejs:18 +20
  • RHSA-2024:1880 Released 2024-04-18 · Red Hat rating Important
    nodejs:18 security update
    • Red Hat Enterprise Linux AppStream EUS (v.8.8) nodejs-1:18.19.1-1.module+el8.8.0+21592+14a8b93e.aarch64::nodejs:18, nodejs-1:18.19.1-1.module+el8.8.0+21592+14a8b93e.ppc64le::nodejs:18, nodejs-1:18.19.1-1.module+el8.8.0+21592+14a8b93e.s390x::nodejs:18 +20
  • RHSA-2024:1687 Released 2024-04-08 · Red Hat rating Important
    nodejs:20 security update
    • Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:20.11.1-1.module+el8.9.0+21380+12032667.aarch64::nodejs:20, nodejs-1:20.11.1-1.module+el8.9.0+21380+12032667.ppc64le::nodejs:20, nodejs-1:20.11.1-1.module+el8.9.0+21380+12032667.s390x::nodejs:20 +20
Show 3 more Red Hat advisories
  • RHSA-2024:1688 Released 2024-04-08 · Red Hat rating Important
    nodejs:20 security update
    • Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:20.11.1-1.module+el9.3.0+21385+bac43d5a.aarch64::nodejs:20, nodejs-1:20.11.1-1.module+el9.3.0+21385+bac43d5a.ppc64le::nodejs:20, nodejs-1:20.11.1-1.module+el9.3.0+21385+bac43d5a.s390x::nodejs:20 +20
  • RHSA-2024:1510 Released 2024-03-26 · Red Hat rating Important
    nodejs:18 security update
    • Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.19.1-1.module+el8.9.0+21387+21356dec.aarch64::nodejs:18, nodejs-1:18.19.1-1.module+el8.9.0+21387+21356dec.ppc64le::nodejs:18, nodejs-1:18.19.1-1.module+el8.9.0+21387+21356dec.s390x::nodejs:18 +20
  • RHSA-2024:1503 Released 2024-03-25 · Red Hat rating Important
    nodejs:18 security update
    • Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.19.1-1.module+el9.3.0+21388+22892fb9.aarch64::nodejs:18, nodejs-1:18.19.1-1.module+el9.3.0+21388+22892fb9.ppc64le::nodejs:18, nodejs-1:18.19.1-1.module+el9.3.0+21388+22892fb9.s390x::nodejs:18 +20

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    NodeJS Node 10.*, 11.* and 16 more versions

    2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2024-14640 A vulnerability in Node.js HTTP servers allows an attacker to send a specially crafted…Priority MEDIUM 45

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2024:1510, RHSA-2024:1687
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2024:1503, RHSA-2024:1688
Red Hat Enterprise Linux AppStream EUS (v.8.8)Fixed RHSA-2024:1880
Red Hat Enterprise Linux AppStream EUS (v.9.2)Fixed RHSA-2024:1932
Not affected: 2 products
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-21892
  2. 2026-10-03 Alias added: GHSA-f27j-4f6g-jp27

References

  • TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
  • TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
  • TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
  • TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
See all 186 →

Sources