Read the docs
TI-2024-14797 Aliases CVE-2024-22204GHSA-hh2q-qv66-jcqg

Whoogle Search Limited File Write vulnerability

Priority MEDIUM 57CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Whoogle Search is a self-hosted metasearch engine. Versions 0.8.3 and prior have a limited file write vulnerability when the configuration options in Whoogle are enabled. The `config` function in `app/routes.py` does not validate the user-controlled `name` variable on line 447 and `config_data` variable on line 437. The `name` variable is insecurely concatenated in `os.path.join`, leading to path manipulation. The POST data from the `config_data` variable is saved with `pickle.dump` which leads to a limited file write. However, the data that is saved is earlier transformed into a dictionary and the `url` key value pair is added before the file is saved on the system. All in all, the issue allows us to save and overwrite files on the system that the application has permissions to, with a dictionary containing arbitrary data and the `url` key value, which is a limited file write. Version 0.8.4 contains a patch for this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00751 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed whoogle-search (benbusby): 0.8.4whoogle-search (PyPI): 0.8.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
benbusbywhoogle-searchbefore 0.8.40.8.4Patch availableCNA
—whoogle-search (PyPI)before 0.8.40.8.4Patch availableGHSA-hh2q-qv66-jcqg
  • whoogle-search Vendorbenbusby Affected before 0.8.4 Fixed in 0.8.4 Patch available CNA
  • whoogle-search (PyPI) Vendor— Affected before 0.8.4 Fixed in 0.8.4 Patch available GHSA-hh2q-qv66-jcqg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:benbusby:whoogle_search:*:*:*:*:*:*:*:*before 0.8.4Vulnerablebenbusby
  • cpe:2.3:a:benbusby:whoogle_search:*:*:*:*:*:*:*:* Versions before 0.8.4 Vulnerable ·benbusby

Remediation

  • Fix · CNA whoogle-search (benbusby) Fixed in 0.8.4
  • Fix · GHSA-hh2q-qv66-jcqg whoogle-search (PyPI) Fixed in 0.8.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-22204
  2. 2026-10-03 Alias added: GHSA-hh2q-qv66-jcqg

References

  • TI-2024-14796 Whoogle Search Server Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-14990 Whoogle Search Cross-site Scripting vulnerability CVSS 3.1MEDIUM 6.1
  • TI-2024-14798 Whoogle Search Server Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-35761 An issue in the component /models/config.py of Whoogle search v0.9.0 allows attackers to… CVSS 3.1HIGH 7.3

Sources