An issue in the component /models/config.py of Whoogle search v0.9.0 allows attackers to…
Priority MEDIUM 41CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
An issue in the component /models/config.py of Whoogle search v0.9.0 allows attackers to execute arbitrary code via supplying a crafted search query.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00594 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed whoogle-search (PyPI): 0.9.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | whoogle-search (PyPI) | before 0.9.1 | 0.9.1 | Patch available | GHSA-2689-cw26-6cpj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- whoogle-search (PyPI) Vendor— Affected before 0.9.1 Fixed in 0.9.1 Patch available GHSA-2689-cw26-6cpj
Remediation
- Fix · GHSA-2689-cw26-6cpj whoogle-search (PyPI) Fixed in 0.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-53305
- 2026-10-03 Alias added: GHSA-2689-cw26-6cpj
References
More benbusby Whoogle Search vulnerabilities
- TI-2024-14796 Whoogle Search Server Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-14990 Whoogle Search Cross-site Scripting vulnerability CVSS 3.1MEDIUM 6.1
- TI-2024-14797 Whoogle Search Limited File Write vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-14798 Whoogle Search Server Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-53305 · CVE Program
- CVE-2024-53305 · NVD
- FIRST EPSS
- GHSA-2689-cw26-6cpj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences