Whoogle Search Cross-site Scripting vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Whoogle Search is a self-hosted metasearch engine. In versions 0.8.3 and prior, the `element` method in `app/routes.py` does not validate the user-controlled `src_type` and `element_url` variables and passes them to the `send` method which sends a `GET` request on lines 339-343 in `requests.py`. The returned contents of the URL are then passed to and reflected back to the user in the `send_file` function on line 484, together with the user-controlled `src_type`, which allows the attacker to control the HTTP response content type leading to a cross-site scripting vulnerability. An attacker could craft a special URL to point to a malicious website and send the link to a victim. The fact that the link would contain a trusted domain (e.g. from one of public Whoogle instances) could be used to trick the user into clicking the link. The malicious website could, for example, be a copy of a real website, meant to steal a person’s credentials to the website, or trick that person in another way. Version 0.8.4 contains a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| benbusby | whoogle-search | before 0.8.4 | 0.8.4 | Patch available | CNA |
| — | whoogle-search (PyPI) | before 0.8.4 | 0.8.4 | Patch available | GHSA-phg6-44m7-hx3h |
- whoogle-search Vendorbenbusby Affected before 0.8.4 Fixed in 0.8.4 Patch available CNA
- whoogle-search (PyPI) Vendor— Affected before 0.8.4 Fixed in 0.8.4 Patch available GHSA-phg6-44m7-hx3h
Remediation
- Fix · CNA whoogle-search (benbusby) Fixed in 0.8.4
- Fix · GHSA-phg6-44m7-hx3h whoogle-search (PyPI) Fixed in 0.8.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22417
- 2026-10-03 Alias added: GHSA-phg6-44m7-hx3h
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
Exploit 1
Advisory 2
Other 8
- https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/request.py#L339-L343
- https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L465-L490
- https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L466
- https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L476
- https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L479
- https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L484C6-L484C7
- https://github.com/benbusby/whoogle-search
- https://github.com/pypa/advisory-database/tree/main/vulns/whoogle-search/PYSEC-2024-19.yaml
More benbusby Whoogle Search vulnerabilities
- TI-2024-14796 Whoogle Search Server Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-14797 Whoogle Search Limited File Write vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-14798 Whoogle Search Server Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-35761 An issue in the component /models/config.py of Whoogle search v0.9.0 allows attackers to… CVSS 3.1HIGH 7.3
Sources
- CVE-2024-22417 · CVE Program
- CVE-2024-22417 · NVD
- FIRST EPSS
- GHSA-phg6-44m7-hx3h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences