Read the docs
TI-2024-15825 Aliases CVE-2024-23831

Privilege escalation through CSRF attack on 'setup.pl'

Priority LOW 35CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

LedgerSMB is a free web-based double-entry accounting system. When a LedgerSMB database administrator has an active session in /setup.pl, an attacker can trick the admin into clicking on a link which automatically submits a request to setup.pl without the admin's consent. This request can be used to create a new user account with full application (/login.pl) privileges, leading to privilege escalation. The vulnerability is patched in versions 1.10.30 and 1.11.9.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00274 19th percentileScored 2026-11-07
Fix Fixed LedgerSMB (ledgersmb): 1.10.30, 1.11.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ledgersmbLedgerSMBbefore 1.10.30; 1.11.0 to before 1.11.91.10.30, 1.11.9Patch availableCNA
  • LedgerSMB Vendorledgersmb Affected before 1.10.30; 1.11.0 to before 1.11.9 Fixed in 1.10.30, 1.11.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:*1.3.0 to before 1.10.30; 1.11.0 to before 1.11.9Vulnerableledgersmb
  • cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* Versions 1.3.0 to before 1.10.30; 1.11.0 to before 1.11.9 Vulnerable ·ledgersmb

Remediation

  • Fix · CNA LedgerSMB (ledgersmb) Fixed in 1.10.30, 1.11.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-23831

References

  • TI-2007-01278 Directory traversal vulnerability in SQL-Ledger, and LedgerSMB before 1.1.5, allows… CVSS 2.0HIGH 10.0
  • TI-2007-03785 Unspecified vulnerability in login.pl in LedgerSMB 1.2.0 through 1.2.6 allows remote… CVSS 2.0HIGH 10.0
  • TI-2021-02628 Cross-site Scripting (XSS) - DOM in ledgersmb/ledgersmb CVSS 3.1CRITICAL 9.6
  • TI-2018-06697 The PGObject::Util::DBAdmin module before 0.120.0 for Perl, as used in LedgerSMB through… CVSS 3.0CRITICAL 9.8
  • TI-2007-05160 Multiple SQL injection vulnerabilities in (a) LedgerSMB 1.0.0 through 1.2.7 and (b) DWS… CVSS 2.0HIGH 10.0
  • TI-2021-02629 Cross-site Scripting (XSS) - Reflected in ledgersmb/ledgersmb CVSS 3.1CRITICAL 9.6
See all 17 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences