Read the docs
TI-2024-16924 Aliases CVE-2024-25723GHSA-vf7j-cmrj-pmmm

ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote…

Priority HIGH 78CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-284.

Summary

ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.70785 99th percentileScored 2026-11-07
Fix Fixed zenml (PyPI): 0.42.2, 0.43.1, 0.46.7 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—zenml (PyPI)before 0.42.20.42.2Patch availableGHSA-vf7j-cmrj-pmmm
—zenml (PyPI)0.43.0 to before 0.43.10.43.1Patch availableGHSA-vf7j-cmrj-pmmm
—zenml (PyPI)0.45.0 to before 0.46.70.46.7Patch availableGHSA-vf7j-cmrj-pmmm
—zenml (PyPI)0.44.0 to before 0.44.40.44.4Patch availableGHSA-vf7j-cmrj-pmmm
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • zenml (PyPI) Vendor— Affected before 0.42.2 Fixed in 0.42.2 Patch available GHSA-vf7j-cmrj-pmmm
  • zenml (PyPI) Vendor— Affected 0.43.0 to before 0.43.1 Fixed in 0.43.1 Patch available GHSA-vf7j-cmrj-pmmm
  • zenml (PyPI) Vendor— Affected 0.45.0 to before 0.46.7 Fixed in 0.46.7 Patch available GHSA-vf7j-cmrj-pmmm
  • zenml (PyPI) Vendor— Affected 0.44.0 to before 0.44.4 Fixed in 0.44.4 Patch available GHSA-vf7j-cmrj-pmmm

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:zenml:zenml:*:*:*:*:*:*:*:*before 0.42.2; 0.44.0 to before 0.44.4; 0.45.0 to before 0.46.7Vulnerablezenml-io
cpe:2.3:a:zenml:zenml:0.43.0:*:*:*:*:*:*:*0.43.0Vulnerablezenml-io
  • cpe:2.3:a:zenml:zenml:*:*:*:*:*:*:*:* Versions before 0.42.2; 0.44.0 to before 0.44.4; 0.45.0 to before 0.46.7 Vulnerable ·zenml-io
  • cpe:2.3:a:zenml:zenml:0.43.0:*:*:*:*:*:*:* Versions 0.43.0 Vulnerable ·zenml-io

Remediation

  • Fix · GHSA-vf7j-cmrj-pmmm zenml (PyPI) Fixed in 0.42.2 Advisory →
  • Fix · GHSA-vf7j-cmrj-pmmm zenml (PyPI) Fixed in 0.43.1 Advisory →
  • Fix · GHSA-vf7j-cmrj-pmmm zenml (PyPI) Fixed in 0.46.7 Advisory →
  • Fix · GHSA-vf7j-cmrj-pmmm zenml (PyPI) Fixed in 0.44.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-25723
  2. 2026-10-03 Alias added: GHSA-vf7j-cmrj-pmmm

References

  • TI-2024-01939 Directory Traversal in zenml-io/zenml CVSS 3.1CRITICAL 9.9
  • TI-2024-08664 Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml CVSS 3.0HIGH 7.5
  • TI-2024-04355 Insufficient Session Expiration in zenml-io/zenml CVSS 3.1HIGH 8.8
  • TI-2025-07692 Path Traversal in zenml-io/zenml CVSS 3.1HIGH 7.8
  • TI-2024-01894 Improper Authorization in zenml-io/zenml CVSS 3.1MEDIUM 6.5
  • TI-2024-04702 Reflected XSS through survey redirect parameter in zenml-io/zenml CVSS 3.1MEDIUM 6.1
See all 13 →

Sources