Path Traversal in zenml-io/zenml
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
ZenML version 0.83.1 is affected by a path traversal vulnerability in the `PathMaterializer` class. The `load` function uses `is_path_within_directory` to validate files during `data.tar.gz` extraction, which fails to effectively detect symbolic and hard links. This vulnerability can lead to arbitrary file writes, potentially resulting in arbitrary command execution if critical files are overwritten.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| zenml-io | zenml-io/zenml | before 0.84.2 | 0.84.2 | Patch available | CNA |
| — | zenml (PyPI) | 0.81.0 to before 0.84.2 | 0.84.2 | Patch available | GHSA-q92x-2x5g-h365 |
- zenml-io/zenml Vendorzenml-io Affected before 0.84.2 Fixed in 0.84.2 Patch available CNA
- zenml (PyPI) Vendor— Affected 0.81.0 to before 0.84.2 Fixed in 0.84.2 Patch available GHSA-q92x-2x5g-h365
Remediation
- Fix · CNA zenml-io/zenml (zenml-io) Fixed in 0.84.2
- Fix · GHSA-q92x-2x5g-h365 zenml (PyPI) Fixed in 0.84.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8406
- 2026-10-03 Alias added: GHSA-q92x-2x5g-h365
References
More zenml-io Zenml vulnerabilities
- TI-2024-16924 ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote… CVSS 3.1HIGH 8.8
- TI-2024-01939 Directory Traversal in zenml-io/zenml CVSS 3.1CRITICAL 9.9
- TI-2024-08664 Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml CVSS 3.0HIGH 7.5
- TI-2024-04355 Insufficient Session Expiration in zenml-io/zenml CVSS 3.1HIGH 8.8
- TI-2024-01894 Improper Authorization in zenml-io/zenml CVSS 3.1MEDIUM 6.5
- TI-2024-04702 Reflected XSS through survey redirect parameter in zenml-io/zenml CVSS 3.1MEDIUM 6.1
Sources
- CVE-2025-8406 · CVE Program
- CVE-2025-8406 · NVD
- FIRST EPSS
- GHSA-q92x-2x5g-h365 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences