Improper Authorization in zenml-io/zenml
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| zenml-io | zenml-io/zenml | before 0.56.2 | 0.56.2 | Patch available | CNA |
| — | zenml (PyPI) | before 0.56.2 | 0.56.2 | Patch available | GHSA-9x88-4jg8-4vf7 |
- zenml-io/zenml Vendorzenml-io Affected before 0.56.2 Fixed in 0.56.2 Patch available CNA
- zenml (PyPI) Vendor— Affected before 0.56.2 Fixed in 0.56.2 Patch available GHSA-9x88-4jg8-4vf7
Remediation
- Fix · CNA zenml-io/zenml (zenml-io) Fixed in 0.56.2
- Fix · GHSA-9x88-4jg8-4vf7 zenml (PyPI) Fixed in 0.56.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
zenml-io/zenml 0.56.2
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-02016 Stored XSS in zenml-io/zenmlPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2035
- 2026-10-03 Alias added: GHSA-9x88-4jg8-4vf7
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
More zenml-io Zenml vulnerabilities
- TI-2024-16924 ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote… CVSS 3.1HIGH 8.8
- TI-2024-01939 Directory Traversal in zenml-io/zenml CVSS 3.1CRITICAL 9.9
- TI-2024-08664 Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml CVSS 3.0HIGH 7.5
- TI-2024-04355 Insufficient Session Expiration in zenml-io/zenml CVSS 3.1HIGH 8.8
- TI-2025-07692 Path Traversal in zenml-io/zenml CVSS 3.1HIGH 7.8
- TI-2024-04702 Reflected XSS through survey redirect parameter in zenml-io/zenml CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-2035 · CVE Program
- CVE-2024-2035 · NVD
- FIRST EPSS
- GHSA-9x88-4jg8-4vf7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences