Read the docs
TI-2024-20503 Aliases CVE-2024-31114GHSA-vh56-p826-446q

WordPress Shortcode Addons <= 3.2.5 - Arbitrary File Upload vulnerability

Priority MEDIUM 44CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.

Summary

Unrestricted Upload of File with Dangerous Type vulnerability in biplob018 Shortcode Addons.This issue affects Shortcode Addons: from n/a through 3.2.5.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01353 71st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Biplob AdhikariShortcode Addonsup to 3.2.5—No fix listedCNA
  • Shortcode Addons VendorBiplob Adhikari Affected up to 3.2.5 Fixed in — No fix listed CNA

CPE names CISA-ADP · 1

CPEVersionsRoleVendor
cpe:2.3:a:oxilab:shortcode_addons:*:*:*:*:*:wordpress:*:*——Biplob Adhikari
  • cpe:2.3:a:oxilab:shortcode_addons:*:*:*:*:*:wordpress:*:* Versions — — ·Biplob Adhikari

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-31114
  2. 2026-10-03 Alias added: GHSA-vh56-p826-446q

References

  • TI-2021-14977 Improper access control in Biplob Adhikari Image Hover Effects Ultimate CVSS 3.1CRITICAL 9.8
  • TI-2022-15381 WordPress Shortcode Addons plugin <= 3.0.2 - Unauthenticated Arbitrary Option Update vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-14629 WordPress Accordions plugin <= 2.0.2 - Unauthenticated WordPress Options Change vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-17812 WordPress Accordions plugin <= 2.0.3 - Auth. WordPress Options Change vulnerability CVSS 3.1HIGH 7.2
  • TI-2022-16714 WordPress Tabs plugin <= 3.6.0 - Authenticated WordPress Options Change vulnerability CVSS 3.1HIGH 7.2
  • TI-2022-14965 WordPress Shortcode Addons plugin <= 3.1.2 - Authenticated WordPress Options Change vulnerability CVSS 3.1HIGH 7.2
See all 28 →

Sources