Read the docs
TI-2024-20811 Aliases CVE-2024-31447GHSA-5297-wrrp-rcj7

Shopware has Improper Session Handling in store-api

Priority LOW 25CWE-613Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-613.

Summary

Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Starting in version 6.3.5.0 and prior to versions 6.6.1.0 and 6.5.8.8, when a authenticated request is made to `POST /store-api/account/logout`, the cart will be cleared, but the User won't be logged out. This affects only the direct store-api usage, as the PHP Storefront listens additionally on `CustomerLogoutEvent` and invalidates the session additionally. The problem has been fixed in Shopware 6.6.1.0 and 6.5.8.8. Those who are unable to update can install the latest version of the Shopware Security Plugin as a workaround.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00499 42nd percentileScored 2026-11-07
Fix Fixed shopware (shopware): 6.5.8.8, 6.6.1.0shopware/core (Packagist): 6.5.8.8, 6.6.1.0+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareshopware6.3.5.0 to before 6.5.8.8; 6.6.0.0-rc1 to before 6.6.1.06.5.8.8, 6.6.1.0Patch availableCNA
—shopware/core (Packagist)6.3.5.0 to before 6.5.8.86.5.8.8Patch availableGHSA-5297-wrrp-rcj7
—shopware/platform (Packagist)6.3.5.0 to before 6.5.8.86.5.8.8Patch availableGHSA-5297-wrrp-rcj7
—shopware/core (Packagist)6.6.0.0-rc1 to before 6.6.1.06.6.1.0Patch availableGHSA-5297-wrrp-rcj7
—shopware/platform (Packagist)6.6.0.0-rc1 to before 6.6.1.06.6.1.0Patch availableGHSA-5297-wrrp-rcj7
  • shopware Vendorshopware Affected 6.3.5.0 to before 6.5.8.8; 6.6.0.0-rc1 to before 6.6.1.0 Fixed in 6.5.8.8, 6.6.1.0 Patch available CNA
  • shopware/core (Packagist) Vendor— Affected 6.3.5.0 to before 6.5.8.8 Fixed in 6.5.8.8 Patch available GHSA-5297-wrrp-rcj7
  • shopware/platform (Packagist) Vendor— Affected 6.3.5.0 to before 6.5.8.8 Fixed in 6.5.8.8 Patch available GHSA-5297-wrrp-rcj7
  • shopware/core (Packagist) Vendor— Affected 6.6.0.0-rc1 to before 6.6.1.0 Fixed in 6.6.1.0 Patch available GHSA-5297-wrrp-rcj7
  • shopware/platform (Packagist) Vendor— Affected 6.6.0.0-rc1 to before 6.6.1.0 Fixed in 6.6.1.0 Patch available GHSA-5297-wrrp-rcj7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*6.3.5.0 to before 6.5.8.8; 6.6.0.0 to before 6.6.1.0Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions 6.3.5.0 to before 6.5.8.8; 6.6.0.0 to before 6.6.1.0 Vulnerable ·shopware

Remediation

  • Fix · CNA shopware (shopware) Fixed in 6.5.8.8, 6.6.1.0
  • Fix · GHSA-5297-wrrp-rcj7 shopware/core (Packagist) Fixed in 6.5.8.8 Advisory →
  • Fix · GHSA-5297-wrrp-rcj7 shopware/platform (Packagist) Fixed in 6.5.8.8 Advisory →
  • Fix · GHSA-5297-wrrp-rcj7 shopware/core (Packagist) Fixed in 6.6.1.0 Advisory →
  • Fix · GHSA-5297-wrrp-rcj7 shopware/platform (Packagist) Fixed in 6.6.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-31447
  2. 2026-10-03 Alias added: GHSA-5297-wrrp-rcj7

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources