Apache Zeppelin: XSS vulnerability in the helium module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can modify helium.json and exposure XSS attacks to normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Zeppelin | 0.8.2 to before 0.11.1 | 0.11.1 | Patch available | CNA |
| — | org.apache.zeppelin:zeppelin-interpreter (Maven) | 0.8.2 to before 0.11.1 | 0.11.1 | Patch available | GHSA-rrvf-5w4r-3x7v |
- Apache Zeppelin VendorApache Affected 0.8.2 to before 0.11.1 Fixed in 0.11.1 Patch available CNA
- org.apache.zeppelin:zeppelin-interpreter (Maven) Vendor— Affected 0.8.2 to before 0.11.1 Fixed in 0.11.1 Patch available GHSA-rrvf-5w4r-3x7v
Remediation
- Fix · CNA Apache Zeppelin (Apache Software Foundation) Fixed in 0.11.1
- Fix · GHSA-rrvf-5w4r-3x7v org.apache.zeppelin:zeppelin-interpreter (Maven) Fixed in 0.11.1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Zeppelin 0.11.1
5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2024-20984 Apache Zeppelin: Interpreter download command does not escape malicious code injectionPriority MEDIUM 52
- TI-2024-20982 Apache Zeppelin: Remote code execution by adding malicious JDBC connection stringPriority MEDIUM 51
- TI-2024-20983 Apache Zeppelin: Cron arbitrary user impersonation with improper privilegesPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2024-31868
- 2026-10-03 Alias added: GHSA-rrvf-5w4r-3x7v
References
Advisory 2
More Apache Zeppelin vulnerabilities
- TI-2024-20984 Apache Zeppelin: Interpreter download command does not escape malicious code injection CVSS 3.1CRITICAL 9.8
- TI-2024-20982 Apache Zeppelin: Remote code execution by adding malicious JDBC connection string CVSS 3.1CRITICAL 9.8
- TI-2019-07420 bash command injection in spark interpreter CVSS 3.1CRITICAL 9.8
- TI-2018-01220 Improper authentication in Apache Zeppelin CVSS 3.0HIGH 8.8
- TI-2017-09344 Session fixation in Apache Zeppelin CVSS 3.0HIGH 8.1
- TI-2024-34954 Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string CVSS 3.1HIGH 7.5
Sources
- CVE-2024-31868 · CVE Program
- CVE-2024-31868 · NVD
- FIRST EPSS
- GHSA-rrvf-5w4r-3x7v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences