WordPress DirectoryPress plugin <= 3.6.7 - Reflected Cross Site Scripting (XSS) vulnerability
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Designinvento DirectoryPress allows Reflected XSS.This issue affects DirectoryPress: from n/a through 3.6.7.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00374 31st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Designinvento | DirectoryPress | up to 3.6.7 | — | No fix listed | CNA |
- DirectoryPress VendorDesigninvento Affected up to 3.6.7 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:designinvento:directorypress:*:*:*:*:*:wordpress:*:* | before 3.6.8 | Vulnerable | Designinvento |
- cpe:2.3:a:designinvento:directorypress:*:*:*:*:*:wordpress:*:* Versions before 3.6.8 Vulnerable ·Designinvento
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32567
- 2026-10-03 Alias added: GHSA-hwwf-q8r7-mppv
References
More Designinvento Directorypress vulnerabilities
- TI-2023-19399 WordPress DirectoryPress plugin <= 3.6.2 - Unauthenticated Broken Access Control Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-25989 WordPress DirectoryPress plugin <= 3.6.10 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-33119 WordPress DirectoryPress plugin <= 3.6.19 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-09806 DirectoryPress <= 3.6.16 - Authenticated (Author+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2024-09803 DirectoryPress Frontend <= 2.7.9 - Cross-Site Request Forgery to Listing Status Update CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-32567 · CVE Program
- CVE-2024-32567 · NVD
- FIRST EPSS
- GHSA-hwwf-q8r7-mppv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences