Read the docs
TI-2024-25989 Aliases CVE-2024-38755GHSA-xrgc-rm8q-pjrp

WordPress DirectoryPress plugin <= 3.6.10 - SQL Injection vulnerability

Priority LOW 39CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Designinvento DirectoryPress allows SQL Injection.This issue affects DirectoryPress: from n/a through 3.6.10.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00656 51st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DesigninventoDirectoryPressup to 3.6.10—No fix listedCNA
  • DirectoryPress VendorDesigninvento Affected up to 3.6.10 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:designinvento:directorypress:*:*:*:*:*:wordpress:*:*up to 3.6.10VulnerableDesigninvento
  • cpe:2.3:a:designinvento:directorypress:*:*:*:*:*:wordpress:*:* Versions up to 3.6.10 Vulnerable ·Designinvento

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-38755
  2. 2026-10-03 Alias added: GHSA-xrgc-rm8q-pjrp
  3. 2026-10-12 EPSS moved to the 50th–90th percentile

References

  • TI-2023-19399 WordPress DirectoryPress plugin <= 3.6.2 - Unauthenticated Broken Access Control Vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-33119 WordPress DirectoryPress plugin <= 3.6.19 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-21454 WordPress DirectoryPress plugin <= 3.6.7 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-09806 DirectoryPress <= 3.6.16 - Authenticated (Author+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
  • TI-2024-09803 DirectoryPress Frontend <= 2.7.9 - Cross-Site Request Forgery to Listing Status Update CVSS 3.1MEDIUM 4.3

Sources