Read the docs
TI-2024-22465 Aliases CVE-2024-33996GHSA-4qww-rxq6-x7gf

moodle: broken access control when setting calendar event type

Priority LOW 28CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Incorrect validation of allowed event types in a calendar web service made it possible for some users to create events with types/audiences they did not have permission to publish to.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00374 31st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 4.3.4, 4.2.7, 4.1.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MoodleMoodle4.0 – 4.3.3; 4.2 – 4.2.6; 4.1 – 4.1.9—No fix listedCNA
—moodle/moodle (Packagist)4.3.0 to before 4.3.44.3.4Patch availableGHSA-4qww-rxq6-x7gf
—moodle/moodle (Packagist)4.2.0 to before 4.2.74.2.7Patch availableGHSA-4qww-rxq6-x7gf
—moodle/moodle (Packagist)before 4.1.104.1.10Patch availableGHSA-4qww-rxq6-x7gf
  • Moodle VendorMoodle Affected 4.0 – 4.3.3; 4.2 – 4.2.6; 4.1 – 4.1.9 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.4 Fixed in 4.3.4 Patch available GHSA-4qww-rxq6-x7gf
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-4qww-rxq6-x7gf
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.10 Fixed in 4.1.10 Patch available GHSA-4qww-rxq6-x7gf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.1.10; 4.2.0 to before 4.2.7; 4.3.0 to before 4.3.4VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.10; 4.2.0 to before 4.2.7; 4.3.0 to before 4.3.4 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-4qww-rxq6-x7gf moodle/moodle (Packagist) Fixed in 4.3.4 Advisory →
  • Fix · GHSA-4qww-rxq6-x7gf moodle/moodle (Packagist) Fixed in 4.2.7 Advisory →
  • Fix · GHSA-4qww-rxq6-x7gf moodle/moodle (Packagist) Fixed in 4.1.10 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-33996
  2. 2026-10-03 Alias added: GHSA-4qww-rxq6-x7gf

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources