moodle: authenticated LFI risk in some misconfigured shared hosting environments via modified mod_data backup
Priority LOW 29CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user with both access to restore database activity modules and direct access to the web server outside of the Moodle webroot could execute a local file include.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00479 41st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 4.3.4, 4.2.7, 4.1.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle | 4.0 – 4.3.3; 4.2 – 4.2.6; 4.1 – 4.1.9 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 4.3.0 to before 4.3.4 | 4.3.4 | Patch available | GHSA-r99q-hmqv-xw8w |
| — | moodle/moodle (Packagist) | 4.2.0 to before 4.2.7 | 4.2.7 | Patch available | GHSA-r99q-hmqv-xw8w |
| — | moodle/moodle (Packagist) | before 4.1.10 | 4.1.10 | Patch available | GHSA-r99q-hmqv-xw8w |
- Moodle Vendor— Affected 4.0 – 4.3.3; 4.2 – 4.2.6; 4.1 – 4.1.9 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.4 Fixed in 4.3.4 Patch available GHSA-r99q-hmqv-xw8w
- moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-r99q-hmqv-xw8w
- moodle/moodle (Packagist) Vendor— Affected before 4.1.10 Fixed in 4.1.10 Patch available GHSA-r99q-hmqv-xw8w
Remediation
- Fix · GHSA-r99q-hmqv-xw8w moodle/moodle (Packagist) Fixed in 4.3.4 Advisory →
- Fix · GHSA-r99q-hmqv-xw8w moodle/moodle (Packagist) Fixed in 4.2.7 Advisory →
- Fix · GHSA-r99q-hmqv-xw8w moodle/moodle (Packagist) Fixed in 4.1.10 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34005
- 2026-10-03 Alias added: GHSA-r99q-hmqv-xw8w
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2024-34005 · CVE Program
- CVE-2024-34005 · NVD
- FIRST EPSS
- GHSA-r99q-hmqv-xw8w · GitHub Advisory Database · CC BY 4.0
- CVE-2024-34005 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences