@strapi/plugin-users-permissions leaks 3rd party authentication tokens and authentication bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass, Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-294 and CWE-601.
Summary
Strapi is an open-source content management system. By combining two vulnerabilities (an `Open Redirect` and `session token sent as URL query parameter`) in @strapi/plugin-users-permissions before version 4.24.2, is its possible of an unauthenticated attacker to bypass authentication mechanisms and retrieve the 3rd party tokens. The attack requires user interaction (one click). Unauthenticated attackers can leverage two vulnerabilities to obtain an 3rd party token and the bypass authentication of Strapi apps. Users should upgrade @strapi/plugin-users-permissions to version 4.24.2 to receive a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Strapi | strapi | before 4.24.2 | 4.24.2 | Patch available | CNA |
| — | @strapi/plugin-users-permissions (npm) | before 4.24.2 | 4.24.2 | Patch available | GHSA-wrvh-rcmr-9qfc |
- strapi VendorStrapi Affected before 4.24.2 Fixed in 4.24.2 Patch available CNA
- @strapi/plugin-users-permissions (npm) Vendor— Affected before 4.24.2 Fixed in 4.24.2 Patch available GHSA-wrvh-rcmr-9qfc
Remediation
- Fix · CNA strapi (strapi) Fixed in 4.24.2
- Fix · GHSA-wrvh-rcmr-9qfc @strapi/plugin-users-permissions (npm) Fixed in 4.24.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34065
- 2026-10-03 Alias added: GHSA-wrvh-rcmr-9qfc
References
More Strapi vulnerabilities
- TI-2023-09037 Query filter flaw in Strapi exposes sensitive user details KEVCVSS 3.1HIGH 7.2
- TI-2019-13554 strapi before 3.0.0-beta.17.5 mishandles password resets within… CVSS 3.1CRITICAL 9.8
- TI-2023-19887 Strapi Improper Rate Limiting vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-08803 Strapi through 4.5.5 allows authenticated Server-Side Template Injection (SSTI) that can… CVSS 3.1CRITICAL 10.0
- TI-2024-25161 Strapi v4.24.4 was discovered to contain a Server-Side Request Forgery (SSRF) via the… CVSS 3.1HIGH 8.6
- TI-2023-17071 Leaking sensitive user information still possible by filtering on private with prefix fields CVSS 3.1HIGH 8.6
Sources
- CVE-2024-34065 · CVE Program
- CVE-2024-34065 · NVD
- FIRST EPSS
- GHSA-wrvh-rcmr-9qfc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences