Command Injection in sagemaker-python-sdk
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
sagemaker-python-sdk is a library for training and deploying machine learning models on Amazon SageMaker. In affected versions the capture_dependencies function in `sagemaker.serve.save_retrive.version_1_0_0.save.utils` module allows for potentially unsafe Operating System (OS) Command Injection if inappropriate command is passed as the “requirements_path” parameter. This consequently may allow an unprivileged third party to cause remote code execution, denial of service, affecting both confidentiality and integrity. This issue has been addressed in version 2.214.3. Users are advised to upgrade. Users unable to upgrade should not override the “requirements_path” parameter of capture_dependencies function in `sagemaker.serve.save_retrive.version_1_0_0.save.utils`, and instead use the default value.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | sagemaker-python-sdk | before 2.214.3 | 2.214.3 | Patch available | CNA |
| — | sagemaker (PyPI) | before 2.214.3 | 2.214.3 | Patch available | GHSA-7pc3-pr3q-58vg |
- sagemaker-python-sdk VendorAWS Affected before 2.214.3 Fixed in 2.214.3 Patch available CNA
- sagemaker (PyPI) Vendor— Affected before 2.214.3 Fixed in 2.214.3 Patch available GHSA-7pc3-pr3q-58vg
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:aws:sagemaker-python-sdk:-:*:*:*:*:*:*:* | not specified by CISA-ADP | — | — |
- cpe:2.3:a:aws:sagemaker-python-sdk:-:*:*:*:*:*:*:* Versions not specified by CISA-ADP — ·—
Remediation
- Fix · CNA sagemaker-python-sdk (aws) Fixed in 2.214.3
- Fix · GHSA-7pc3-pr3q-58vg sagemaker (PyPI) Fixed in 2.214.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34073
- 2026-10-03 Alias added: GHSA-7pc3-pr3q-58vg
References
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2024-34073 · CVE Program
- CVE-2024-34073 · NVD
- FIRST EPSS
- GHSA-7pc3-pr3q-58vg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences