Read the docs
TI-2024-25209 Aliases CVE-2024-37893GHSA-4gm4-c4mh-4p7w

MFA bypass in oauth flow in Firefly III

Priority LOW 27CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

Firefly III is a free and open source personal finance manager. In affected versions an MFA bypass in the Firefly III OAuth flow may allow malicious users to bypass the MFA-check. This allows malicious users to use password spraying to gain access to Firefly III data using passwords stolen from other sources. As OAuth applications are easily enumerable using an incrementing id, an attacker could try sign an OAuth application up to a users profile quite easily if they have created one. The attacker would also need to know the victims username and password. This problem has been patched in Firefly III v6.1.17 and up. Users are advised to upgrade. Users unable to upgrade should Use a unique password for their Firefly III instance and store their password securely, i.e. in a password manager.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00594 48th percentileScored 2026-11-07
Fix Fixed firefly-iii (firefly-iii): 6.1.17grumpydictator/firefly-iii (Packagist): 6.1.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
firefly-iiifirefly-iiibefore 6.1.176.1.17Patch availableCNA
—grumpydictator/firefly-iii (Packagist)before 6.1.176.1.17Patch availableGHSA-4gm4-c4mh-4p7w
  • firefly-iii Vendorfirefly-iii Affected before 6.1.17 Fixed in 6.1.17 Patch available CNA
  • grumpydictator/firefly-iii (Packagist) Vendor— Affected before 6.1.17 Fixed in 6.1.17 Patch available GHSA-4gm4-c4mh-4p7w

Remediation

  • Fix · CNA firefly-iii (firefly-iii) Fixed in 6.1.17
  • Fix · GHSA-4gm4-c4mh-4p7w grumpydictator/firefly-iii (Packagist) Fixed in 6.1.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-37893
  2. 2026-10-03 Alias added: GHSA-4gm4-c4mh-4p7w

References

  • TI-2023-01681 Improper Input Validation in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
  • TI-2023-01680 Insufficient Session Expiration in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
  • TI-2023-00283 Incorrect Authorization in firefly-iii/firefly-iii CVSS 3.1MEDIUM 6.5
  • TI-2019-10251 Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of… CVSS 3.1MEDIUM 5.4
  • TI-2021-02811 Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
  • TI-2021-02777 Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
See all 27 →

Sources