moodle: BigBlueButton web service leaks meeting joining information to users who should not have access
Priority LOW 25CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Insufficient capability checks meant it was possible for users to gain access to BigBlueButton join URLs they did not have permission to access.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00429 37th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 4.4.1, 4.3.5, 4.2.8 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Moodle | Moodle | 4.4; 4.3 – 4.3.4; 4.2 – 4.2.7; 4.1 – 4.1.10 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.1 | 4.4.1 | Patch available | GHSA-x29x-qwvx-fxr2 |
| — | moodle/moodle (Packagist) | 4.3.0-beta to before 4.3.5 | 4.3.5 | Patch available | GHSA-x29x-qwvx-fxr2 |
| — | moodle/moodle (Packagist) | 4.2.0-beta to before 4.2.8 | 4.2.8 | Patch available | GHSA-x29x-qwvx-fxr2 |
| — | moodle/moodle (Packagist) | before 4.1.11 | 4.1.11 | Patch available | GHSA-x29x-qwvx-fxr2 |
- Moodle VendorMoodle Affected 4.4; 4.3 – 4.3.4; 4.2 – 4.2.7; 4.1 – 4.1.10 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.1 Fixed in 4.4.1 Patch available GHSA-x29x-qwvx-fxr2
- moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.5 Fixed in 4.3.5 Patch available GHSA-x29x-qwvx-fxr2
- moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.2.8 Fixed in 4.2.8 Patch available GHSA-x29x-qwvx-fxr2
- moodle/moodle (Packagist) Vendor— Affected before 4.1.11 Fixed in 4.1.11 Patch available GHSA-x29x-qwvx-fxr2
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 4.1.0 to before 4.1.11; 4.2.0 to before 4.2.8; 4.3.0 to before 4.3.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.4.0:*:*:*:*:*:*:* | 4.4.0 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.1.0 to before 4.1.11; 4.2.0 to before 4.2.8; 4.3.0 to before 4.3.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.4.0:*:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-x29x-qwvx-fxr2 moodle/moodle (Packagist) Fixed in 4.4.1 Advisory →
- Fix · GHSA-x29x-qwvx-fxr2 moodle/moodle (Packagist) Fixed in 4.3.5 Advisory →
- Fix · GHSA-x29x-qwvx-fxr2 moodle/moodle (Packagist) Fixed in 4.2.8 Advisory →
- Fix · GHSA-x29x-qwvx-fxr2 moodle/moodle (Packagist) Fixed in 4.1.11 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38273
- 2026-10-03 Alias added: GHSA-x29x-qwvx-fxr2
References
Advisory 2
Other 9
- https://lists.fedoraproject.org/archives/list/[email protected]/message/GHTIX55J4Q4LEOMLNEA4OZSWVEENQX7E/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/F7AZYR7EXV6E5SQE2GYTNQE3NOENJCQ6/
- https://github.com/moodle/moodle/commit/500cec575731fd8575569dcb5811535751dddae1
- https://github.com/moodle/moodle/commit/647b9dc06409211018c9f28581504d096ce9e3a8
- https://github.com/moodle/moodle/commit/6c0645ca29b195b5caaffc27d80f2ff715c33a48
- https://github.com/moodle/moodle/commit/a10506b8d70609478fef156d489e0c7d727b6098
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/[email protected]/message/F7AZYR7EXV6E5SQE2GYTNQE3NOENJCQ6
- https://lists.fedoraproject.org/archives/list/[email protected]/message/GHTIX55J4Q4LEOMLNEA4OZSWVEENQX7E
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2024-38273 · CVE Program
- CVE-2024-38273 · NVD
- FIRST EPSS
- GHSA-x29x-qwvx-fxr2 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-38273 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences