Read the docs
TI-2024-25553 Aliases CVE-2024-38275GHSA-p2cj-86v4-7782

moodle: HTTP authorization header is preserved between "emulated redirects"

Priority LOW 39CWE-226Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

The cURL wrapper in Moodle retained the original request headers when following redirects, so HTTP authorization header information could be unintentionally sent in requests to redirect URLs.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00449 39th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 4.4.1, 4.3.5, 4.2.8 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MoodleMoodle4.4; 4.3 – 4.3.4; 4.2 – 4.2.7; 4.1 – 4.1.10—No fix listedCNA
—moodle/moodle (Packagist)4.4.0-beta to before 4.4.14.4.1Patch availableGHSA-p2cj-86v4-7782
—moodle/moodle (Packagist)4.3.0-beta to before 4.3.54.3.5Patch availableGHSA-p2cj-86v4-7782
—moodle/moodle (Packagist)4.2.0-beta to before 4.2.84.2.8Patch availableGHSA-p2cj-86v4-7782
—moodle/moodle (Packagist)before 4.1.114.1.11Patch availableGHSA-p2cj-86v4-7782
  • Moodle VendorMoodle Affected 4.4; 4.3 – 4.3.4; 4.2 – 4.2.7; 4.1 – 4.1.10 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.1 Fixed in 4.4.1 Patch available GHSA-p2cj-86v4-7782
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.5 Fixed in 4.3.5 Patch available GHSA-p2cj-86v4-7782
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.2.8 Fixed in 4.2.8 Patch available GHSA-p2cj-86v4-7782
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.11 Fixed in 4.1.11 Patch available GHSA-p2cj-86v4-7782

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.1.11; 4.2.0 to before 4.2.8; 4.3.0 to before 4.3.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:4.4.0:*:*:*:*:*:*:*4.4.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.11; 4.2.0 to before 4.2.8; 4.3.0 to before 4.3.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:4.4.0:*:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-p2cj-86v4-7782 moodle/moodle (Packagist) Fixed in 4.4.1 Advisory →
  • Fix · GHSA-p2cj-86v4-7782 moodle/moodle (Packagist) Fixed in 4.3.5 Advisory →
  • Fix · GHSA-p2cj-86v4-7782 moodle/moodle (Packagist) Fixed in 4.2.8 Advisory →
  • Fix · GHSA-p2cj-86v4-7782 moodle/moodle (Packagist) Fixed in 4.1.11 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-38275
  2. 2026-10-03 Alias added: GHSA-p2cj-86v4-7782

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources