moodle: CSRF risks due to misuse of confirm_sesskey
Priority LOW 38CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Incorrect CSRF token checks resulted in multiple CSRF risks.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00459 40th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 4.4.1, 4.3.5, 4.2.8 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Moodle | Moodle | 4.4; 4.3 – 4.3.4; 4.2 – 4.2.7; 4.1 – 4.1.10 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.1 | 4.4.1 | Patch available | GHSA-356g-7x36-7m34 |
| — | moodle/moodle (Packagist) | 4.3.0-beta to before 4.3.5 | 4.3.5 | Patch available | GHSA-356g-7x36-7m34 |
| — | moodle/moodle (Packagist) | 4.2.0-beta to before 4.2.8 | 4.2.8 | Patch available | GHSA-356g-7x36-7m34 |
| — | moodle/moodle (Packagist) | before 4.1.11 | 4.1.11 | Patch available | GHSA-356g-7x36-7m34 |
- Moodle VendorMoodle Affected 4.4; 4.3 – 4.3.4; 4.2 – 4.2.7; 4.1 – 4.1.10 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.1 Fixed in 4.4.1 Patch available GHSA-356g-7x36-7m34
- moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.5 Fixed in 4.3.5 Patch available GHSA-356g-7x36-7m34
- moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.2.8 Fixed in 4.2.8 Patch available GHSA-356g-7x36-7m34
- moodle/moodle (Packagist) Vendor— Affected before 4.1.11 Fixed in 4.1.11 Patch available GHSA-356g-7x36-7m34
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.1.10; 4.2.0 to before 4.2.8; 4.3.0 to before 4.3.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.4.0:*:*:*:*:*:*:* | 4.4.0 | Vulnerable | Moodle |
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.10; 4.2.0 to before 4.2.8; 4.3.0 to before 4.3.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.4.0:*:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·Moodle
Remediation
- Fix · GHSA-356g-7x36-7m34 moodle/moodle (Packagist) Fixed in 4.4.1 Advisory →
- Fix · GHSA-356g-7x36-7m34 moodle/moodle (Packagist) Fixed in 4.3.5 Advisory →
- Fix · GHSA-356g-7x36-7m34 moodle/moodle (Packagist) Fixed in 4.2.8 Advisory →
- Fix · GHSA-356g-7x36-7m34 moodle/moodle (Packagist) Fixed in 4.1.11 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38276
- 2026-10-03 Alias added: GHSA-356g-7x36-7m34
References
Advisory 3
Other 19
- https://github.com/moodle/moodle/commit/f2807dee5bc777d9c58b7a70cba6e4c21ee02ea1
- https://github.com/moodle/moodle/commit/e23f603c41055ab92f9b430cf0e7a54b4e120f95
- https://github.com/moodle/moodle/commit/e1dab5f38166a2ff62983178f7bf8f0ed3a61090
- https://github.com/moodle/moodle/commit/dc84fcfab06a4a0fe37797b8422e9fe3a1031c3e
- https://github.com/moodle/moodle/commit/da8e8cee6ffaf7c184eded97e1016f20c9de0561
- https://github.com/moodle/moodle/commit/c5b1604e8136db6d72057dd8052955058489206c
- https://github.com/moodle/moodle/commit/c1aacb3e2884ea4dcc221c5ef2e449ce345f78ae
- https://github.com/moodle/moodle/commit/c18b59808cefe7b54c85dce6bf2cc71601080667
- https://github.com/moodle/moodle/commit/a0d8c025f732d5c18a2b9d1a8e5cbee35dce86f4
- https://github.com/moodle/moodle/commit/9af9711c0a78ebad87d49bcb369ff813bc57d0a7
- https://github.com/moodle/moodle/commit/756090ed79aa056d0b5f58e7a1dff67f139f76b4
- https://github.com/moodle/moodle/commit/57f20b6cb352893871c3afdfa8a4c09a96e16764
- https://github.com/moodle/moodle/commit/31ced0851189a6879e4cd27c7e65d21dd9d6e87e
- https://github.com/moodle/moodle/commit/30fadc3686fa7490860a0bd87a29636139dfb371
- https://github.com/moodle/moodle/commit/137d311fd1354c679b974633512a771e6e0559a1
- https://github.com/moodle/moodle/commit/093aedf79889114d004495f05969168b646b0285
- https://lists.fedoraproject.org/archives/list/[email protected]/message/F7AZYR7EXV6E5SQE2GYTNQE3NOENJCQ6
- https://lists.fedoraproject.org/archives/list/[email protected]/message/GHTIX55J4Q4LEOMLNEA4OZSWVEENQX7E
- https://github.com/moodle/moodle
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2024-38276 · CVE Program
- CVE-2024-38276 · NVD
- FIRST EPSS
- GHSA-356g-7x36-7m34 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-38276 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences