Read the docs
TI-2024-27964 Aliases CVE-2024-41942GHSA-9x4q-3gxw-849f

JupyterHub has a privilege escalation vulnerability with the `admin:users` scope

Priority LOW 32CWE-274Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to versions 4.1.6 and 5.1.0, if a user is granted the `admin:users` scope, they may escalate their own privileges by making themselves a full admin user. The impact is relatively small in that `admin:users` is already an extremely privileged scope only granted to trusted users. In effect, `admin:users` is equivalent to `admin=True`, which is not intended. Note that the change here only prevents escalation to the built-in JupyterHub admin role that has unrestricted permissions. It does not prevent users with e.g. `groups` permissions from granting themselves or other users permissions via group membership, which is intentional. Versions 4.1.6 and 5.1.0 fix this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed jupyterhub (jupyterhub): 4.1.6, 5.1.0jupyterhub (PyPI): 4.1.6, 5.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
jupyterhubjupyterhubbefore 4.1.6; 5.0.0 to before 5.1.04.1.6, 5.1.0Patch availableCNA
—jupyterhub (PyPI)before 4.1.64.1.6Patch availableGHSA-9x4q-3gxw-849f
—jupyterhub (PyPI)5.0.0 to before 5.1.05.1.0Patch availableGHSA-9x4q-3gxw-849f
  • jupyterhub Vendorjupyterhub Affected before 4.1.6; 5.0.0 to before 5.1.0 Fixed in 4.1.6, 5.1.0 Patch available CNA
  • jupyterhub (PyPI) Vendor— Affected before 4.1.6 Fixed in 4.1.6 Patch available GHSA-9x4q-3gxw-849f
  • jupyterhub (PyPI) Vendor— Affected 5.0.0 to before 5.1.0 Fixed in 5.1.0 Patch available GHSA-9x4q-3gxw-849f

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:jupyter:jupyterhub:*:*:*:*:*:*:*:*before 4.1.6Vulnerablejupyterlab
cpe:2.3:a:jupyter:jupyterhub:5.0.0:-:*:*:*:*:*:*5.0.0Vulnerablejupyterlab
cpe:2.3:a:jupyter:jupyterhub:5.0.0:beta1:*:*:*:*:*:*5.0.0 beta1Vulnerablejupyterlab
cpe:2.3:a:jupyter:jupyterhub:5.0.0:beta2:*:*:*:*:*:*5.0.0 beta2Vulnerablejupyterlab
  • cpe:2.3:a:jupyter:jupyterhub:*:*:*:*:*:*:*:* Versions before 4.1.6 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:jupyterhub:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:jupyterhub:5.0.0:beta1:*:*:*:*:*:* Versions 5.0.0 beta1 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:jupyterhub:5.0.0:beta2:*:*:*:*:*:* Versions 5.0.0 beta2 Vulnerable ·jupyterlab

Remediation

  • Fix · CNA jupyterhub (jupyterhub) Fixed in 4.1.6, 5.1.0
  • Fix · GHSA-9x4q-3gxw-849f jupyterhub (PyPI) Fixed in 4.1.6 Advisory →
  • Fix · GHSA-9x4q-3gxw-849f jupyterhub (PyPI) Fixed in 5.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-41942
  2. 2026-10-03 Alias added: GHSA-9x4q-3gxw-849f

References

  • TI-2025-23499 Jupyter Remote Desktop Proxy makes TigerVNC accessible via the network and not just via a UNIX socket as intended CVSS 4.0CRITICAL 9.0
  • TI-2023-10877 JupyterHub's LTI13Authenticator: JWT signature not validated CVSS 3.1CRITICAL 10.0
  • TI-2021-16545 Remote code execution in Binderhub CVSS 3.1CRITICAL 9.8
  • TI-2021-18033 Improper Access Control in jupyterhub-firstuseauthenticator CVSS 3.1CRITICAL 9.8
  • TI-2021-16546 Code injection in nbgitpuller CVSS 3.1CRITICAL 9.6
  • TI-2024-18755 Jupyter Server Proxy's Websocket Proxying does not require authentication CVSS 3.1CRITICAL 9.8
See all 23 →

Sources