Read the docs
TI-2024-28341 Aliases CVE-2024-42354GHSA-hhcq-ph6w-494g

Shopware vulnerable to Improper Access Control with ManyToMany associations in store-api

Priority LOW 27CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.

Summary

Shopware is an open commerce platform. The store-API works with regular entities and not expose all fields for the public API; fields need to be marked as ApiAware in the EntityDefinition. So only ApiAware fields of the EntityDefinition will be encoded to the final JSON. Prior to versions 6.6.5.1 and 6.5.8.13, the processing of the Criteria did not considered ManyToMany associations and so they were not considered properly and the protections didn't get used. This issue cannot be reproduced with the default entities by Shopware, but can be triggered with extensions. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00429 37th percentileScored 2026-11-07
Fix Fixed shopware/core (Packagist): 6.5.8.13, 6.6.5.1shopware/platform (Packagist): 6.5.8.13, 6.6.5.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareshopwareup to 6.5.8.12; 6.6.0.0 – 6.6.5.0—No fix listedCNA
—shopware/core (Packagist)before 6.5.8.136.5.8.13Patch availableGHSA-hhcq-ph6w-494g
—shopware/platform (Packagist)before 6.5.8.136.5.8.13Patch availableGHSA-hhcq-ph6w-494g
—shopware/core (Packagist)6.6.0.0 to before 6.6.5.16.6.5.1Patch availableGHSA-hhcq-ph6w-494g
—shopware/platform (Packagist)6.6.0.0 to before 6.6.5.16.6.5.1Patch availableGHSA-hhcq-ph6w-494g
  • shopware Vendorshopware Affected up to 6.5.8.12; 6.6.0.0 – 6.6.5.0 Fixed in — No fix listed CNA
  • shopware/core (Packagist) Vendor— Affected before 6.5.8.13 Fixed in 6.5.8.13 Patch available GHSA-hhcq-ph6w-494g
  • shopware/platform (Packagist) Vendor— Affected before 6.5.8.13 Fixed in 6.5.8.13 Patch available GHSA-hhcq-ph6w-494g
  • shopware/core (Packagist) Vendor— Affected 6.6.0.0 to before 6.6.5.1 Fixed in 6.6.5.1 Patch available GHSA-hhcq-ph6w-494g
  • shopware/platform (Packagist) Vendor— Affected 6.6.0.0 to before 6.6.5.1 Fixed in 6.6.5.1 Patch available GHSA-hhcq-ph6w-494g

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.5.8.13; 6.6.0.0 to before 6.6.5.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.5.8.13; 6.6.0.0 to before 6.6.5.1 Vulnerable ·shopware

Remediation

  • Fix · GHSA-hhcq-ph6w-494g shopware/core (Packagist) Fixed in 6.5.8.13 Advisory →
  • Fix · GHSA-hhcq-ph6w-494g shopware/platform (Packagist) Fixed in 6.5.8.13 Advisory →
  • Fix · GHSA-hhcq-ph6w-494g shopware/core (Packagist) Fixed in 6.6.5.1 Advisory →
  • Fix · GHSA-hhcq-ph6w-494g shopware/platform (Packagist) Fixed in 6.6.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-42354
  2. 2026-10-03 Alias added: GHSA-hhcq-ph6w-494g

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources