Shopware vulnerable to blind SQL-injection in DAL aggregations
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the Shopware application API contains a search functionality which enables users to search through information stored within their Shopware instance. The searches performed by this function can be aggregated using the parameters in the `aggregations` object. The `name` field in this `aggregations` object is vulnerable SQL-injection and can be exploited using SQL parameters. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | shopware | 6.6.0.0 – 6.6.5.0; up to 6.5.8.12 | — | No fix listed | CNA |
| — | shopware/core (Packagist) | before 6.5.8.13 | 6.5.8.13 | Patch available | GHSA-p6w9-r443-r752 |
| — | shopware/platform (Packagist) | before 6.5.8.13 | 6.5.8.13 | Patch available | GHSA-p6w9-r443-r752 |
| — | shopware/platform (Packagist) | 6.6.0.0 to before 6.6.5.1 | 6.6.5.1 | Patch available | GHSA-p6w9-r443-r752 |
| — | shopware/core (Packagist) | 6.6.0.0 to before 6.6.5.1 | 6.6.5.1 | Patch available | GHSA-p6w9-r443-r752 |
- shopware Vendorshopware Affected 6.6.0.0 – 6.6.5.0; up to 6.5.8.12 Fixed in — No fix listed CNA
- shopware/core (Packagist) Vendor— Affected before 6.5.8.13 Fixed in 6.5.8.13 Patch available GHSA-p6w9-r443-r752
- shopware/platform (Packagist) Vendor— Affected before 6.5.8.13 Fixed in 6.5.8.13 Patch available GHSA-p6w9-r443-r752
- shopware/platform (Packagist) Vendor— Affected 6.6.0.0 to before 6.6.5.1 Fixed in 6.6.5.1 Patch available GHSA-p6w9-r443-r752
- shopware/core (Packagist) Vendor— Affected 6.6.0.0 to before 6.6.5.1 Fixed in 6.6.5.1 Patch available GHSA-p6w9-r443-r752
Remediation
- Fix · GHSA-p6w9-r443-r752 shopware/core (Packagist) Fixed in 6.5.8.13 Advisory →
- Fix · GHSA-p6w9-r443-r752 shopware/platform (Packagist) Fixed in 6.5.8.13 Advisory →
- Fix · GHSA-p6w9-r443-r752 shopware/platform (Packagist) Fixed in 6.6.5.1 Advisory →
- Fix · GHSA-p6w9-r443-r752 shopware/core (Packagist) Fixed in 6.6.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-42357
- 2026-10-03 Alias added: GHSA-p6w9-r443-r752
References
Patch 4
- https://github.com/shopware/core/commit/63c05615694790f5790a04ef889f42b764fa53c9
- https://github.com/shopware/core/commit/a784aa1cec0624e36e0ee4d41aeebaed40e0442f
- https://github.com/shopware/shopware/commit/57ea2f3c59483cf7c0f853e7a0d68c23ded1fe5b
- https://github.com/shopware/shopware/commit/8504ba7e56e53add6a1d5b9d45015e3d899cd0ac
Advisory 2
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-42357 · CVE Program
- CVE-2024-42357 · NVD
- FIRST EPSS
- GHSA-p6w9-r443-r752 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences