Read the docs
TI-2024-28399 Aliases CVE-2024-42422GHSA-4878-4h8j-fwv8

Authorization bypass in Dell NetWorker

Priority MEDIUM 42CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-639.

Summary

Dell NetWorker, version(s) 19.10, contain(s) an Authorization Bypass Through User-Controlled Key vulnerability. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to Information disclosure.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00292 21st percentileScored 2026-11-07
Fix Fixed NetWorker (Dell): 19.10.0.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DellNetWorker19.11 – 19.11.0.2; N/A to before 19.10.0.619.10.0.6Patch availableCNA
  • NetWorker VendorDell Affected 19.11 – 19.11.0.2; N/A to before 19.10.0.6 Fixed in 19.10.0.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dell:networker:*:*:*:*:*:*:*:*before 19.10.0.6; 19.11 to before 19.11.0.3VulnerableDell
  • cpe:2.3:a:dell:networker:*:*:*:*:*:*:*:* Versions before 19.10.0.6; 19.11 to before 19.11.0.3 Vulnerable ·Dell

Remediation

  • Fix · CNA NetWorker (Dell) Fixed in 19.10.0.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-42422
  2. 2026-10-03 Alias added: GHSA-4878-4h8j-fwv8

References

  • TI-2023-10843 Code injection in Dell NetWorker NVE CVSS 3.1CRITICAL 9.8
  • TI-2023-12637 Improper authorization in Dell NetWorker CVSS 3.1HIGH 8.8
  • TI-2025-15103 Dell NetWorker, version(s) prior to 19.11.0.3, all versions of 19.10 & prior versions… CVSS 3.1HIGH 7.8
  • TI-2025-15099 Dell NetWorker Management Console, version(s) 19.11 through 19.11.0.3 & Versions prior to… CVSS 3.1HIGH 7.8
  • TI-2024-15003 Insufficiently protected credentials in Dell NetWorker Module for Databases and… CVSS 3.1HIGH 7.8
  • TI-2025-24895 Dell NetWorker, versions 19.12.0.1 and prior, contains a Selection of Less-Secure… CVSS 3.1HIGH 7.5
See all 8 →

Sources