WordPress PowerPack for Beaver Builder plugin < 2.37.4 - Reflected Cross Site Scripting (XSS) vulnerability
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in IdeaBox Creations PowerPack for Beaver Builder allows Reflected XSS.This issue affects PowerPack for Beaver Builder: from n/a before 2.37.4.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00272 19th percentileScored 2026-11-07
Fix Fixed PowerPack for Beaver Builder (IdeaBox Creations): 2.37.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ideaboxcreations | PowerPack for Beaver Builder | before 2.37.4 | 2.37.4 | Patch available | CNA |
- PowerPack for Beaver Builder Vendorideaboxcreations Affected before 2.37.4 Fixed in 2.37.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ideabox:powerpack_for_beaver_builder:*:*:*:*:pro:wordpress:*:* | before 2.37.4 | Vulnerable | ideaboxcreations |
- cpe:2.3:a:ideabox:powerpack_for_beaver_builder:*:*:*:*:pro:wordpress:*:* Versions before 2.37.4 Vulnerable ·ideaboxcreations
Remediation
- Fix · CNA PowerPack for Beaver Builder (IdeaBox Creations) Fixed in 2.37.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-43330
- 2026-10-03 Alias added: GHSA-f97w-c3mj-6vh6
References
More ideaboxcreations Powerpack For Beaver Builder vulnerabilities
- TI-2024-24914 WordPress PowerPack Lite for Beaver Builder plugin <= 1.3.0.3 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.2
- TI-2022-00117 PowerPack Lite for Beaver Builder < 1.2.9.3 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-02126 PowerPack Lite for Beaver Builder <= 1.3.0 - Authenticated(Contributor+) Stored Cross-Site Scripting via element link CVSS 3.1MEDIUM 6.4
- TI-2024-11353 PowerPack Lite for Beaver Builder <= 1.3.0.5 - Reflected Cross-Site Scripting via Navigate Parameter CVSS 3.1MEDIUM 6.1
- TI-2024-24913 WordPress PowerPack Lite for Beaver Builder plugin <= 1.3.0.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-43330 · CVE Program
- CVE-2024-43330 · NVD
- FIRST EPSS
- GHSA-f97w-c3mj-6vh6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences