Moodle: admin presets export tool includes some secrets that should not be exported
Priority LOW 18CWE-922Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-922.
Summary
A flaw was found in moodle. When creating an export of site administration presets, some sensitive secrets and keys are not being excluded from the export, which could result in them unintentionally being leaked if the presets are shared with a third party.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00337 27th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.12, 4.2.9, 4.3.6 +1moodle/moodle (Packagist): 4.4.2, 4.3.6, 4.2.9 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | before 4.1.12; 4.2 to before 4.2.9; 4.3 to before 4.3.6; 4.4 to before 4.4.2 | 4.1.12, 4.2.9, 4.3.6, 4.4.2 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 4.4.0 to before 4.4.2 | 4.4.2 | Patch available | GHSA-vpq5-56jj-vf2m |
| — | moodle/moodle (Packagist) | 4.3.0 to before 4.3.6 | 4.3.6 | Patch available | GHSA-vpq5-56jj-vf2m |
| — | moodle/moodle (Packagist) | 4.2.0 to before 4.2.9 | 4.2.9 | Patch available | GHSA-vpq5-56jj-vf2m |
| — | moodle/moodle (Packagist) | before 4.1.12 | 4.1.12 | Patch available | GHSA-vpq5-56jj-vf2m |
- moodle Vendor— Affected before 4.1.12; 4.2 to before 4.2.9; 4.3 to before 4.3.6; 4.4 to before 4.4.2 Fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 4.4.0 to before 4.4.2 Fixed in 4.4.2 Patch available GHSA-vpq5-56jj-vf2m
- moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.6 Fixed in 4.3.6 Patch available GHSA-vpq5-56jj-vf2m
- moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.9 Fixed in 4.2.9 Patch available GHSA-vpq5-56jj-vf2m
- moodle/moodle (Packagist) Vendor— Affected before 4.1.12 Fixed in 4.1.12 Patch available GHSA-vpq5-56jj-vf2m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.1.12; 4.2.0 to before 4.2.9; 4.3.0 to before 4.3.6; 4.4.0 to before 4.4.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.12; 4.2.0 to before 4.2.9; 4.3.0 to before 4.3.6; 4.4.0 to before 4.4.2 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2
- Fix · GHSA-vpq5-56jj-vf2m moodle/moodle (Packagist) Fixed in 4.4.2 Advisory →
- Fix · GHSA-vpq5-56jj-vf2m moodle/moodle (Packagist) Fixed in 4.3.6 Advisory →
- Fix · GHSA-vpq5-56jj-vf2m moodle/moodle (Packagist) Fixed in 4.2.9 Advisory →
- Fix · GHSA-vpq5-56jj-vf2m moodle/moodle (Packagist) Fixed in 4.1.12 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-43427
- 2026-10-03 Alias added: GHSA-vpq5-56jj-vf2m
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2024-43427 · CVE Program
- CVE-2024-43427 · NVD
- FIRST EPSS
- GHSA-vpq5-56jj-vf2m · GitHub Advisory Database · CC BY 4.0
- CVE-2024-43427 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences