Moodle: matrix user/power level management not always working as expected with suspended users
Priority LOW 30CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
A flaw was found in moodle. Matrix room membership and power levels are incorrectly applied and revoked for suspended Moodle users.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00327 25th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.12, 4.2.9, 4.3.6 +1moodle/moodle (Packagist): 4.4.2, 4.3.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | before 4.1.12; 4.2 to before 4.2.9; 4.3 to before 4.3.6; 4.4 to before 4.4.2 | 4.1.12, 4.2.9, 4.3.6, 4.4.2 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 4.4.0 to before 4.4.2 | 4.4.2 | Patch available | GHSA-q99x-mjmh-v8w7 |
| — | moodle/moodle (Packagist) | 4.3.0 to before 4.3.6 | 4.3.6 | Patch available | GHSA-q99x-mjmh-v8w7 |
- moodle Vendor— Affected before 4.1.12; 4.2 to before 4.2.9; 4.3 to before 4.3.6; 4.4 to before 4.4.2 Fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 4.4.0 to before 4.4.2 Fixed in 4.4.2 Patch available GHSA-q99x-mjmh-v8w7
- moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.6 Fixed in 4.3.6 Patch available GHSA-q99x-mjmh-v8w7
Remediation
- Fix · CNA moodle Fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2
- Fix · GHSA-q99x-mjmh-v8w7 moodle/moodle (Packagist) Fixed in 4.4.2 Advisory →
- Fix · GHSA-q99x-mjmh-v8w7 moodle/moodle (Packagist) Fixed in 4.3.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-43433
- 2026-10-03 Alias added: GHSA-q99x-mjmh-v8w7
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2024-43433 · CVE Program
- CVE-2024-43433 · NVD
- FIRST EPSS
- GHSA-q99x-mjmh-v8w7 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-43433 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences