Read the docs
TI-2024-29086 Aliases CVE-2024-43440GHSA-qrqv-26gf-xgwh

Moodle: lfi vulnerability when restoring malformed block backups

Priority MEDIUM 40CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

A flaw was found in moodle. A local file may include risks when restoring block backups.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00647 51st percentileScored 2026-11-07
Fix Fixed moodle: 4.1.12, 4.2.9, 4.3.6 +1moodle/moodle (Packagist): 4.1.12, 4.2.9, 4.3.6 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodlebefore 4.1.12; 4.2 to before 4.2.9; 4.3 to before 4.3.6; 4.4 to before 4.4.24.1.12, 4.2.9, 4.3.6, 4.4.2Patch availableCNA
—moodle/moodle (Packagist)before 4.1.124.1.12Patch availableGHSA-qrqv-26gf-xgwh
—moodle/moodle (Packagist)4.2.0-beta to before 4.2.94.2.9Patch availableGHSA-qrqv-26gf-xgwh
—moodle/moodle (Packagist)4.3.0-beta to before 4.3.64.3.6Patch availableGHSA-qrqv-26gf-xgwh
—moodle/moodle (Packagist)4.4.0-beta to before 4.4.24.4.2Patch availableGHSA-qrqv-26gf-xgwh
  • moodle Vendor— Affected before 4.1.12; 4.2 to before 4.2.9; 4.3 to before 4.3.6; 4.4 to before 4.4.2 Fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.12 Fixed in 4.1.12 Patch available GHSA-qrqv-26gf-xgwh
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.2.9 Fixed in 4.2.9 Patch available GHSA-qrqv-26gf-xgwh
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.6 Fixed in 4.3.6 Patch available GHSA-qrqv-26gf-xgwh
  • moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.2 Fixed in 4.4.2 Patch available GHSA-qrqv-26gf-xgwh

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.1.12; 4.2.0 to before 4.2.9; 4.3.0 to before 4.3.6; 4.4.0 to before 4.4.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.12; 4.2.0 to before 4.2.9; 4.3.0 to before 4.3.6; 4.4.0 to before 4.4.2 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.1.12, 4.2.9, 4.3.6, 4.4.2
  • Fix · GHSA-qrqv-26gf-xgwh moodle/moodle (Packagist) Fixed in 4.1.12 Advisory →
  • Fix · GHSA-qrqv-26gf-xgwh moodle/moodle (Packagist) Fixed in 4.2.9 Advisory →
  • Fix · GHSA-qrqv-26gf-xgwh moodle/moodle (Packagist) Fixed in 4.3.6 Advisory →
  • Fix · GHSA-qrqv-26gf-xgwh moodle/moodle (Packagist) Fixed in 4.4.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-43440
  2. 2026-10-03 Alias added: GHSA-qrqv-26gf-xgwh
  3. 2026-10-19 EPSS moved to the 50th–90th percentile

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources