Read the docs
TI-2024-29668 Aliases CVE-2024-44088GHSA-w595-4975-gm3h

Apache Geode: Reflected XSS

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2 Users are recommended to upgrade to version 1.15.2, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00689 53rd percentileScored 2026-11-07
Fix Fixed Apache Geode (Apache Software Foundation): 1.15.2org.apache.geode:geode-web-api (Maven): 1.15.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Geode1.1.0 to before 1.15.21.15.2Patch availableCNA
—org.apache.geode:geode-web-api (Maven)1.1.0 to before 1.15.21.15.2Patch availableGHSA-w595-4975-gm3h
  • Apache Geode VendorApache Affected 1.1.0 to before 1.15.2 Fixed in 1.15.2 Patch available CNA
  • org.apache.geode:geode-web-api (Maven) Vendor— Affected 1.1.0 to before 1.15.2 Fixed in 1.15.2 Patch available GHSA-w595-4975-gm3h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:geode:*:*:*:*:*:*:*:*1.1.0 to before 1.15.2VulnerableApache
  • cpe:2.3:a:apache:geode:*:*:*:*:*:*:*:* Versions 1.1.0 to before 1.15.2 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Geode (Apache Software Foundation) Fixed in 1.15.2
  • Fix · GHSA-w595-4975-gm3h org.apache.geode:geode-web-api (Maven) Fixed in 1.15.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-44088
  2. 2026-10-03 Alias added: GHSA-w595-4975-gm3h

References

  • TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
  • TI-2019-11096 Information disclosure in Red Hat jackson-databind CVSS 3.1CRITICAL 9.8
  • TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
  • TI-2017-11466 Deserialization of untrusted data in Apache Geode CVSS 3.0CRITICAL 9.8
  • TI-2022-17225 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. CVSS 3.1CRITICAL 9.8
See all 22 →

Sources