Read the docs
TI-2024-30144 Aliases CVE-2024-45031GHSA-jmrf-85g8-x8xv

Apache Syncope: Stored XSS in Console and Enduser

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

When editing objects in the Syncope Console, incomplete HTML tags could be used to bypass HTML sanitization. This made it possible to inject stored XSS payloads which would trigger for other users during ordinary usage of the application. XSS payloads could also be injected in Syncope Enduser when editing “Personal Information” or “User Requests”: such payloads would trigger for administrators in Syncope Console, thus enabling session hijacking. Users are recommended to upgrade to version 3.0.9, which fixes this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00708 53rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Syncope2.1 – 2.1.14; 3.0 – 3.0.8—No fix listedCNA
—org.apache.syncope.client:syncope-client-console (Maven)2.1.0 – 2.1.14—No fix listedGHSA-jmrf-85g8-x8xv
  • Apache Syncope VendorApache Affected 2.1 – 2.1.14; 3.0 – 3.0.8 Fixed in — No fix listed CNA
  • org.apache.syncope.client:syncope-client-console (Maven) Vendor— Affected 2.1.0 – 2.1.14 Fixed in — No fix listed GHSA-jmrf-85g8-x8xv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*2.1.0 to before 3.0.9VulnerableApache
  • cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:* Versions 2.1.0 to before 3.0.9 Vulnerable ·Apache

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-45031
  2. 2026-10-03 Alias added: GHSA-jmrf-85g8-x8xv

References

  • TI-2025-35632 Apache Syncope: Remote Code Execution by delegated administrators CVSS 3.1HIGH 7.2
  • TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
  • TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
  • TI-2026-44406 Apache Syncope: User self-service privilege escalation CVSS 3.1CRITICAL 9.8
  • TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
  • TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
See all 23 →

Sources