XML External Entity Reference (XXE) in PHPSpreadsheet
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Affected versions are subject to a bypassing of a filter which allows for an XXE-attack. This in turn allows attacker to obtain contents of local files, even if error reporting is muted. This vulnerability has been addressed in release version 2.2.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHPOffice | PhpSpreadsheet | before 2.2.1 | 2.2.1 | Patch available | CNA |
| — | phpoffice/phpspreadsheet (Packagist) | before 1.29.1 | 1.29.1 | Patch available | GHSA-ghg6-32f9-2jp7 |
| — | phpoffice/phpspreadsheet (Packagist) | 2.2.0 to before 2.2.1 | 2.2.1 | Patch available | GHSA-ghg6-32f9-2jp7 |
| — | phpoffice/phpspreadsheet (Packagist) | 2.0.0 to before 2.1.1 | 2.1.1 | Patch available | GHSA-ghg6-32f9-2jp7 |
| — | phpoffice/phpexcel (Packagist) | up to 1.8.2 | — | No fix listed | GHSA-ghg6-32f9-2jp7 |
- PhpSpreadsheet VendorPHPOffice Affected before 2.2.1 Fixed in 2.2.1 Patch available CNA
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.29.1 Fixed in 1.29.1 Patch available GHSA-ghg6-32f9-2jp7
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-ghg6-32f9-2jp7
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-ghg6-32f9-2jp7
- phpoffice/phpexcel (Packagist) Vendor— Affected up to 1.8.2 Fixed in — No fix listed GHSA-ghg6-32f9-2jp7
Remediation
- Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 2.2.1
- Fix · GHSA-ghg6-32f9-2jp7 phpoffice/phpspreadsheet (Packagist) Fixed in 1.29.1 Advisory →
- Fix · GHSA-ghg6-32f9-2jp7 phpoffice/phpspreadsheet (Packagist) Fixed in 2.2.1 Advisory →
- Fix · GHSA-ghg6-32f9-2jp7 phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45048
- 2026-10-03 Alias added: GHSA-ghg6-32f9-2jp7
References
More PHPOffice Phpspreadsheet vulnerabilities
- TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
- TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
- TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
- TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
- TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
- TI-2026-29558 PhpSpreadsheet: CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions CVSS 3.1HIGH 7.5
Sources
- CVE-2024-45048 · CVE Program
- CVE-2024-45048 · NVD
- FIRST EPSS
- GHSA-ghg6-32f9-2jp7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences