PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to unauthorized reflected cross-site scripting in the `Currency.php` file. Using the `/vendor/phpoffice/phpspreadsheet/samples/Wizards/NumberFormat/Currency.php` script, an attacker can perform a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHPOffice | PhpSpreadsheet | 3.0.0 to before 3.7.0; before 1.29.7; 2.0.0 to before 2.1.6; 2.2.0 to before 2.3.5 | 3.7.0, 1.29.7, 2.1.6, 2.3.5 | Patch available | CNA |
| — | phpoffice/phpspreadsheet (Packagist) | 3.0.0 to before 3.7.0 | 3.7.0 | Patch available | GHSA-j2xg-cjcx-4677 |
| — | phpoffice/phpspreadsheet (Packagist) | before 1.29.7 | 1.29.7 | Patch available | GHSA-j2xg-cjcx-4677 |
| — | phpoffice/phpspreadsheet (Packagist) | 2.0.0 to before 2.1.6 | 2.1.6 | Patch available | GHSA-j2xg-cjcx-4677 |
| — | phpoffice/phpspreadsheet (Packagist) | 2.2.0 to before 2.3.5 | 2.3.5 | Patch available | GHSA-j2xg-cjcx-4677 |
| — | phpoffice/phpexcel (Packagist) | up to 1.8.2 | — | No fix listed | GHSA-j2xg-cjcx-4677 |
- PhpSpreadsheet VendorPHPOffice Affected 3.0.0 to before 3.7.0; before 1.29.7; 2.0.0 to before 2.1.6; 2.2.0 to before 2.3.5 Fixed in 3.7.0, 1.29.7, 2.1.6, 2.3.5 Patch available CNA
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 3.0.0 to before 3.7.0 Fixed in 3.7.0 Patch available GHSA-j2xg-cjcx-4677
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.29.7 Fixed in 1.29.7 Patch available GHSA-j2xg-cjcx-4677
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.6 Fixed in 2.1.6 Patch available GHSA-j2xg-cjcx-4677
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.3.5 Fixed in 2.3.5 Patch available GHSA-j2xg-cjcx-4677
- phpoffice/phpexcel (Packagist) Vendor— Affected up to 1.8.2 Fixed in — No fix listed GHSA-j2xg-cjcx-4677
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* | before 1.29.7; 2.0.0 to before 2.1.6; 2.2.0 to before 2.3.5; 3.3.0 to before 3.7.0 | Vulnerable | PHPOffice |
- cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* Versions before 1.29.7; 2.0.0 to before 2.1.6; 2.2.0 to before 2.3.5; 3.3.0 to before 3.7.0 Vulnerable ·PHPOffice
Remediation
- Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 3.7.0, 1.29.7, 2.1.6, 2.3.5
- Fix · GHSA-j2xg-cjcx-4677 phpoffice/phpspreadsheet (Packagist) Fixed in 3.7.0 Advisory →
- Fix · GHSA-j2xg-cjcx-4677 phpoffice/phpspreadsheet (Packagist) Fixed in 1.29.7 Advisory →
- Fix · GHSA-j2xg-cjcx-4677 phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.6 Advisory →
- Fix · GHSA-j2xg-cjcx-4677 phpoffice/phpspreadsheet (Packagist) Fixed in 2.3.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-56409
- 2026-10-03 Alias added: GHSA-j2xg-cjcx-4677
References
More PHPOffice Phpspreadsheet vulnerabilities
- TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
- TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
- TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
- TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
- TI-2024-30160 XML External Entity Reference (XXE) in PHPSpreadsheet CVSS 3.1HIGH 8.8
- TI-2026-29558 PhpSpreadsheet: CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions CVSS 3.1HIGH 7.5
Sources
- CVE-2024-56409 · CVE Program
- CVE-2024-56409 · NVD
- FIRST EPSS
- GHSA-j2xg-cjcx-4677 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences